summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-24 03:38:46 +0000
committerSam James <sam@gentoo.org>2021-10-24 03:38:59 +0000
commit6fe5661c2c211076587b54ff97e06bef9f69d864 (patch)
tree44e46b7d2abebde9f1c0df5943371ba55071b49e /net-analyzer
parentnet-analyzer/fail2ban: fix install with newer setuptools (2to3 usage) (diff)
downloadgentoo-6fe5661c2c211076587b54ff97e06bef9f69d864.tar.gz
gentoo-6fe5661c2c211076587b54ff97e06bef9f69d864.tar.bz2
gentoo-6fe5661c2c211076587b54ff97e06bef9f69d864.zip
net-analyzer/fail2ban: backport upstream test fix for systemd
Closes: https://bugs.gentoo.org/794931 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.11.2-r1.ebuild3
-rw-r--r--net-analyzer/fail2ban/files/fail2ban-0.11.2-fix-systemd-test.patch22
2 files changed, 24 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.11.2-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.11.2-r1.ebuild
index 3e667a2f5738..52bfd2a78f2a 100644
--- a/net-analyzer/fail2ban/fail2ban-0.11.2-r1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.11.2-r1.ebuild
@@ -40,7 +40,8 @@ DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
PATCHES=(
"${FILESDIR}"/${P}-fix-tests-for-2021.patch
"${FILESDIR}"/${PN}-0.11.2-adjust-apache-logs-paths.patch
- "${FILESDIR}"/${PN}-0.11.2-fix-2to3-usage.patch
+ "${FILESDIR}"/${P}-fix-2to3-usage.patch
+ "${FILESDIR}"/${P}-fix-systemd-test.patch
)
python_prepare_all() {
diff --git a/net-analyzer/fail2ban/files/fail2ban-0.11.2-fix-systemd-test.patch b/net-analyzer/fail2ban/files/fail2ban-0.11.2-fix-systemd-test.patch
new file mode 100644
index 000000000000..865ce19912bb
--- /dev/null
+++ b/net-analyzer/fail2ban/files/fail2ban-0.11.2-fix-systemd-test.patch
@@ -0,0 +1,22 @@
+https://github.com/fail2ban/fail2ban/pull/3037
+https://bugs.gentoo.org/794931
+
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Tue, 8 Jun 2021 17:48:12 -0400
+Subject: [PATCH] tests: improve detection of readable systemd journal
+
+Look for system.journal in journal sub-directory.
+Add -readable to the find command.
+
+Bug: https://bugs.gentoo.org/794931
+--- a/fail2ban/tests/filtertestcase.py
++++ b/fail2ban/tests/filtertestcase.py
+@@ -1396,7 +1396,7 @@ def _getRuntimeJournal(self):
+ # check one at at time until the first hit
+ for systemd_var in 'system-runtime-logs', 'system-state-logs':
+ tmp = Utils.executeCmd(
+- 'find "$(systemd-path %s)" -name system.journal' % systemd_var,
++ 'find "$(systemd-path %s)/journal" -name system.journal -readable' % systemd_var,
+ timeout=10, shell=True, output=True
+ )
+ self.assertTrue(tmp)