summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-03 07:06:07 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-03 07:06:39 +0200
commit83424b9c6ab73fb550383c2820f3a2128ecc015d (patch)
tree11fa8136e381767258e9b07cc42eb9469647e9cc /net-analyzer
parentnet-analyzer/cacti: Version 1.2.14 (diff)
downloadgentoo-83424b9c6ab73fb550383c2820f3a2128ecc015d.tar.gz
gentoo-83424b9c6ab73fb550383c2820f3a2128ecc015d.tar.bz2
gentoo-83424b9c6ab73fb550383c2820f3a2128ecc015d.zip
net-analyzer/cacti-spine: Version 1.2.14
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.14.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 98369352a790..ce570009bfd0 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1 +1,2 @@
DIST cacti-spine-1.2.13.tar.gz 107543 BLAKE2B e0de75688334d27604a76c00a09ac53587a1e57f45df925e30a1a88a5e0449df803dfad901328c65b55484bc9022bf81d53880f17d4bd4efd9214315f01f7e92 SHA512 86d44195847c7b3acb1f6aed2bd6a57f562645b20724560d6b4bf7962707be4eb2f5326731453937b64420b5d51b714aecbd8dbea58d95f29ef4341515df8b00
+DIST cacti-spine-1.2.14.tar.gz 107577 BLAKE2B 5865d93ffefeeafac1d2245000467deac79f8008e81b66de310bf08e7aa31f17299a82fc107ad49c3741bc2f183bdbc9554f814bf9e3e4b1dc85e267e4f16112 SHA512 44dec1077b419dfc987a1d423f2df597bf2026ca7f39aaafabfc7de9e6fdc616f505b86ace43bb2ad628f220cf8d8cf136a04f00c4fd23ab73da75068f804999
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.14.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.14.ebuild
new file mode 100644
index 000000000000..a5c1da23c064
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.14.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}