summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-15 09:56:15 +0100
committerSam James <sam@gentoo.org>2023-04-15 10:32:28 +0100
commit898a04f72679015c6f82e5fd230c780a2249a63e (patch)
tree0a1afb74237f247be9e671f0594d89a7c8b8c61e /net-analyzer
parentapp-crypt/yubikey-manager: drop 4.0.8-r1 (diff)
downloadgentoo-898a04f72679015c6f82e5fd230c780a2249a63e.tar.gz
gentoo-898a04f72679015c6f82e5fd230c780a2249a63e.tar.bz2
gentoo-898a04f72679015c6f82e5fd230c780a2249a63e.zip
net-analyzer/tcpflow: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895282 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpflow/files/tcpflow-1.6.1-gcc13.patch22
-rw-r--r--net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/net-analyzer/tcpflow/files/tcpflow-1.6.1-gcc13.patch b/net-analyzer/tcpflow/files/tcpflow-1.6.1-gcc13.patch
new file mode 100644
index 000000000000..d3b6b63920f1
--- /dev/null
+++ b/net-analyzer/tcpflow/files/tcpflow-1.6.1-gcc13.patch
@@ -0,0 +1,22 @@
+https://github.com/simsong/tcpflow/pull/252
+
+From 51973125e3961569b83bd4fdde65272a3843a6a3 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 15 Apr 2023 09:54:14 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes and so etc is no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+Bug: https://bugs.gentoo.org/895282
+--- a/src/netviz/plot_view.h
++++ b/src/netviz/plot_view.h
+@@ -23,6 +23,7 @@
+ #include <cairo/cairo-pdf.h>
+ #endif
+
++#include <cstdint>
+ #include <vector>
+ #include <string>
+ #include <math.h>
+
diff --git a/net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild b/net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild
index 07306743ad75..ab313f301712 100644
--- a/net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild
+++ b/net-analyzer/tcpflow/tcpflow-1.6.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -37,6 +37,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.5.0_alpha-libcapng.patch
"${FILESDIR}"/${PN}-1.5.2-gentoo.patch
"${FILESDIR}"/${PN}-1.6.1-wformat-security.patch
+ "${FILESDIR}"/${PN}-1.6.1-gcc13.patch
)
src_prepare() {