summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-30 11:49:23 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-30 11:49:30 +0200
commit90ef900223244786e7b7a07ce9c47978ba075dd0 (patch)
treede15ac7b0ff00f14e4459ff8dbfadbb14ca561d7 /net-analyzer
parentnet-libs/nodejs: amd64 stable wrt bug #742893 (diff)
downloadgentoo-90ef900223244786e7b7a07ce9c47978ba075dd0.tar.gz
gentoo-90ef900223244786e7b7a07ce9c47978ba075dd0.tar.bz2
gentoo-90ef900223244786e7b7a07ce9c47978ba075dd0.zip
net-analyzer/tcptrace: Version 6.6.7_p6
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcptrace/Manifest1
-rw-r--r--net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/tcptrace/Manifest b/net-analyzer/tcptrace/Manifest
index 38a5487049c3..9d4cc81f6006 100644
--- a/net-analyzer/tcptrace/Manifest
+++ b/net-analyzer/tcptrace/Manifest
@@ -1,3 +1,4 @@
DIST tcptrace-6.6.7.tar.gz 3773308 BLAKE2B cae5816cb25c33f71c316d14de3c18ff26f0e7452375a962b88c4818ca7c43425e7298e788bd8cb43f2e22ac7dc9b89ed1921b7bd70d0e8befab3ee791453fb1 SHA512 3638770c342aea6c71aa556e758ed22e1fd44730f6c652cf82d3861eb1c31b186952c660071bd1df45020b80eaf9dd090a4ff58c979cc907eb8154dcb7b9b432
DIST tcptrace_6.6.7-4.1.diff.gz 29161 BLAKE2B 83768d0a6f14525f20b484421181078a3cf7ac3adeada3cf02a7441530593632743c6e515dd8738f5a4692422d97f4eb718dda076a234489096a10defb97dd5f SHA512 2f6dfeb8e15faa0151bdbb18194587e51de040f63117eb1b469a826091d5c1e5eb41a306bdc94e89ce993d0d04ec31324e5f7eea0a1a52852e07ee80006b2087
DIST tcptrace_6.6.7-5.debian.tar.xz 6236 BLAKE2B 21d35b625fdc7b94c29b2be595ac39488578f08c53e5dde98953bbebaa2d8d96de968b746dd107ea78365a77f1fe7aa5abfeb3aeef4473c9020587f93066000c SHA512 6265d0bfb25f256c8f356cda731c48f869fe3e9d9504ed6afd0e98a3c2caf5dbcff73373c338be111712713b9a501fae886bb06723796103bac4dec5d8fcfaf6
+DIST tcptrace_6.6.7-6.debian.tar.xz 6056 BLAKE2B a46a8a8a8f804066486566bccd10e33dc372a1fc30f37f401913c2b3038cf917891472e93a509cac8bdd2928d473c3ce21d0c4048c96ae54967fc48780384221 SHA512 82eebc2e297130cbafab0bb1757402d8b210885320ded1cd9b7ff064248d145c93196820564d4d1d7f1b1f7391cc5f734a0e0bf6275ddcae106d0bd540e32b61
diff --git a/net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild b/net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild
new file mode 100644
index 000000000000..f08f5f8fd7de
--- /dev/null
+++ b/net-analyzer/tcptrace/tcptrace-6.6.7_p6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A Tool for analyzing network packet dumps"
+HOMEPAGE="http://www.tcptrace.org/"
+SRC_URI="
+ http://www.tcptrace.org/download/${P/_p*}.tar.gz
+ http://www.tcptrace.org/download/old/6.6/${P/_p*}.tar.gz
+ mirror://debian/pool/main/t/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P/_p*}-cross-compile.patch
+ "${FILESDIR}"/${P/_p*}-_DEFAULT_SOURCE.patch
+)
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+ default
+
+ eapply \
+ $(awk '{ print "'"${WORKDIR}"'/debian/patches/" $0; }' < "${WORKDIR}"/debian/patches/series)
+
+ eautoreconf
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcptrace xpl2gpl
+
+ newman tcptrace.man tcptrace.1
+ dodoc CHANGES COPYRIGHT FAQ README* THANKS WWW
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Note: tcptrace outputs its graphs in the xpl (xplot)"
+ elog "format. Since xplot is unavailable, you will have to"
+ elog "use the included xpl2gpl utility to convert it to"
+ elog "the gnuplot format."
+ fi
+}