summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-02 12:19:02 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-02 12:43:42 +0200
commit9ba2635768ec1b941ece310c1496c07cc5792843 (patch)
tree0fe32542e791c5a7daea35aac48cb391a31afdd5 /net-analyzer
parentdev-python/pyilmbase: change to python-single-r1 (diff)
downloadgentoo-9ba2635768ec1b941ece310c1496c07cc5792843.tar.gz
gentoo-9ba2635768ec1b941ece310c1496c07cc5792843.tar.bz2
gentoo-9ba2635768ec1b941ece310c1496c07cc5792843.zip
net-analyzer/nfdump: Version 1.6.21
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Bug: https://bugs.gentoo.org/712590 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nfdump/Manifest1
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.21.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-analyzer/nfdump/Manifest b/net-analyzer/nfdump/Manifest
index a576e2cdefd2..8e6ae49f88b8 100644
--- a/net-analyzer/nfdump/Manifest
+++ b/net-analyzer/nfdump/Manifest
@@ -1,2 +1,3 @@
DIST nfdump-1.6.19.tar.gz 561923 BLAKE2B 458cf0e23f433c7c1c27450712a2f9f8f75a990eeaf079bac9a74bf5abf4bc22c930294494424fd8e7f7d03ffc1e5f1e35ba50e29ba4f3528f63e1739524c9ed SHA512 577c23ca3aae8ab035c734c137d3a338e09f46b5f8551946fd84b9a03fae1ef2aa80e2ab9657eb226defcd753bb63503eeb85316ca1df18d95b85270df8f379e
DIST nfdump-1.6.20.tar.gz 561053 BLAKE2B 20c8db09386a4aa6174d3c2919c33409a4b2d9b295908ae61e8ce12107c08ba7742fb7ec80bcb7bcdb15e036e6d2320c83f0446a479185cb18717720eca87c88 SHA512 8396241fa24d532540135762a81ce035586c405d4ab1e01d6e2b8226b7cc9b6784170ca1fa4c1581fb60f324473cca5ce2d3de82282313d3877f9584e449d137
+DIST nfdump-1.6.21.tar.gz 561617 BLAKE2B 61a52cb7ee724c47f93e0ce8dd0515306c16b94d8b351f9543deecc2b28c813f09f0e4ba621f2561760924af683ffd527d00936fbc5f91f83d6f727d6cf9e5d9 SHA512 c9162b7a6653267cd4d66a2d75bb2c3d65c431bb29ee549bac2a208fe7f2bc871bb91dfa6d89d6f18cd69f1d435dd25ba1c5dfe6e10b0efc4a582f2e67913a34
diff --git a/net-analyzer/nfdump/nfdump-1.6.21.ebuild b/net-analyzer/nfdump/nfdump-1.6.21.ebuild
new file mode 100644
index 000000000000..4c59fb92baec
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.6.21.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="https://github.com/phaag/nfdump"
+SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1.6.15"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc ftconv nfprofile nftrack readpcap sflow static-libs"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
+ nfprofile? ( net-analyzer/rrdtool )
+ nftrack? ( net-analyzer/rrdtool )
+ readpcap? ( net-libs/libpcap )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.19-compiler.patch
+ "${FILESDIR}"/${PN}-1.6.19-libft.patch
+)
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use doc; then
+ doxygen -u doc/Doxyfile.in || die
+ fi
+}
+
+src_configure() {
+ # --without-ftconf is not handled well #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfprofile && echo --enable-nfprofile) \
+ $(use nftrack && echo --enable-nftrack) \
+ $(use_enable debug devel) \
+ $(use_enable readpcap) \
+ $(use_enable sflow) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use doc; then
+ dodoc -r doc/html
+ fi
+}