summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-07-21 20:09:11 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-07-21 20:14:17 +0200
commit9cdd8170be4f65331a6b27aebfb1a7a2aa2b479d (patch)
tree9732fc73a7faef50f0644a4979fa9a178739b79b /net-analyzer
parentdev-python/pooch: re-created Manifest (diff)
downloadgentoo-9cdd8170be4f65331a6b27aebfb1a7a2aa2b479d.tar.gz
gentoo-9cdd8170be4f65331a6b27aebfb1a7a2aa2b479d.tar.bz2
gentoo-9cdd8170be4f65331a6b27aebfb1a7a2aa2b479d.zip
net-analyzer/nagios-plugins-linux-madrisan: add 29
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/Manifest1
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-29.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/Manifest b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
index 05211a1f35d1..ce8e9ff25694 100644
--- a/net-analyzer/nagios-plugins-linux-madrisan/Manifest
+++ b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
@@ -1,2 +1,3 @@
DIST nagios-plugins-linux-madrisan-27.tar.xz 385324 BLAKE2B ef207e365d044fefa8c0dbef7aae8a50ec9b6c70d60d069574ed423646d1e936e0bd6bbb316070d94f354236f815e508da4ec1b298e89958c8393a041f98a908 SHA512 5d93912f2237449e29e963cca260fbe7a735f47e7c2752402e2f371289e2875e4fea35f191705d7a2f01ac49381e039b720f43c8c794e85ee0bbbb01d212a10a
DIST nagios-plugins-linux-madrisan-28.tar.xz 390428 BLAKE2B bc41fb7d3b639fe2d133c2ff6643562ce94e5523b13aa18045d7265ae8d9d80873b0611aaee0f0fa8b959e0da3e2c350868574a8986c0d9436b6bd4e4154d908 SHA512 c72065ade12ec60c86479276370215bc0dc419ae9681d7260c550f8985300c39c1c8e39537c51c56e0c1ae61283befc5d111ffd47394de7dc7f7daa5993254fc
+DIST nagios-plugins-linux-madrisan-29.tar.xz 392700 BLAKE2B edc93bfb113cb12ce8a345e38627881decb952cb1e7a948dcdced2aaa9c940956b75a7c8f7ad1b72daac132236ab27762b6f8b14a5098eaac648bafae6dfdb33 SHA512 412464b894fe2a0953e495c7c87604ed6b282f65fd1988043757b162ba4fecf9e8f9740e7e09ec2dad8ba8d80fa928df4d7e644260538117d19776f4883045f6
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-29.ebuild b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-29.ebuild
new file mode 100644
index 000000000000..7d39abb43437
--- /dev/null
+++ b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-29.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="nagios-plugins-linux"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Additional and alternative Nagios plugins for Linux"
+HOMEPAGE="https://github.com/madrisan/nagios-plugins-linux"
+SRC_URI="https://github.com/madrisan/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl varlink"
+
+DEPEND="
+ curl? ( net-misc/curl:0= )
+ varlink? ( dev-libs/libvarlink:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # Avoid collision with net-analyzer/monitoring-plugins
+ # and net-analyzer/nagios-plugins
+ sed -ri "s/check_(load|swap|uptime|users)/&_madrisan/" plugins/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/nagios/plugins"
+ # Most options are already defaults for Gentoo
+ --disable-hardening
+ $(use_enable curl libcurl)
+ $(use_enable varlink libvarlink)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake check VERBOSE=1
+}