summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-04-25 20:23:28 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-04-25 20:29:05 -0400
commita299e275255caae5bb040d250763c746340b8336 (patch)
tree507b5a5847bc58187a4b153dca1bd2e03a173d72 /net-analyzer
parentnet-analyzer/nagios-core: remove old revision nagios-core-4.0.8-r1. (diff)
downloadgentoo-a299e275255caae5bb040d250763c746340b8336.tar.gz
gentoo-a299e275255caae5bb040d250763c746340b8336.tar.bz2
gentoo-a299e275255caae5bb040d250763c746340b8336.zip
net-analyzer/nagios-core: new patch and revision to fix logo installation.
The fix for bug 388321 required a patch, but that patch broke the installation of the theme logos (which live in their own directory). That patch has been updated as a new revision, use-INSTALL-to-install-themes-r1.patch, to avoid impacting nagios-core-4.0.8-r2.ebuild which is stable on amd64. The new revision nagios-4.1.1-r1 should pick up the new patch. Gentoo-Bug: 388321 Gentoo-Bug: 581148 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-core/files/use-INSTALL-to-install-themes-r1.patch65
-rw-r--r--net-analyzer/nagios-core/nagios-core-4.1.1-r1.ebuild (renamed from net-analyzer/nagios-core/nagios-core-4.1.1.ebuild)6
2 files changed, 68 insertions, 3 deletions
diff --git a/net-analyzer/nagios-core/files/use-INSTALL-to-install-themes-r1.patch b/net-analyzer/nagios-core/files/use-INSTALL-to-install-themes-r1.patch
new file mode 100644
index 000000000000..a14f5a39b056
--- /dev/null
+++ b/net-analyzer/nagios-core/files/use-INSTALL-to-install-themes-r1.patch
@@ -0,0 +1,65 @@
+From b6552e3b0b006fa28014150d199813de12d89ef4 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 25 Apr 2016 20:06:18 -0400
+Subject: [PATCH 1/1] Use $(INSTALL) to install themes.
+
+Most of the images installed under the htdocs folder are installed
+mode 644 with owner:group nagios:nagios. This is due to the use of
+$(INSTALL) in html/Makefile. However, the theme images and stylesheets
+are currently installed with a simple "cp -r", which leads to
+inconsistencies like the following:
+
+ $ cd /usr/share/nagios/htdocs/images
+ $ ls action*.gif
+ -rw-rw-r-- 1 nagios nagios 1.3K 2014-11-12 08:22 action.gif
+ -rw-r--r-- 1 root root 1.3K 2014-11-12 08:22 action-graph.gif
+ -rw-r--r-- 1 root root 171 2014-11-12 08:22 action-nagios.gif
+ -rw-r--r-- 1 root root 162 2014-11-12 08:22 action-orig.gif
+
+By using $(INSTALL) in the install-exfoliation and install-classicui
+targets, we enforce some consistency.
+---
+ Makefile.in | 20 ++++++++++++++++----
+ 1 file changed, 16 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 5b97513..0ec50b7 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -300,8 +300,14 @@ install-webconf:
+ @echo ""
+
+ install-exfoliation:
+- cp -rf contrib/exfoliation/stylesheets/* $(DESTDIR)$(HTMLDIR)/stylesheets
+- cp -rf contrib/exfoliation/images/* $(DESTDIR)$(HTMLDIR)/images
++ for file in contrib/exfoliation/stylesheets/*.*; \
++ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/stylesheets; done
++
++ for file in contrib/exfoliation/images/*.*; \
++ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images; done
++
++ for file in contrib/exfoliation/images/logos/*.*; \
++ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images/logos; done
+
+ @echo ""
+ @echo "*** Exfoliation theme installed ***"
+@@ -309,8 +315,14 @@ install-exfoliation:
+ @echo ""
+
+ install-classicui:
+- cp -rf html/stylesheets/* $(DESTDIR)$(HTMLDIR)/stylesheets
+- cp -rf html/images/* $(DESTDIR)$(HTMLDIR)/images
++ for file in html/stylesheets/*.*; \
++ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/stylesheets; done
++
++ for file in html/images/*.*; \
++ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images; done
++
++ for file in html/images/logos/*.*; \
++ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images/logos; done
+
+ @echo ""
+ @echo "*** Classic theme installed ***"
+--
+2.7.3
+
diff --git a/net-analyzer/nagios-core/nagios-core-4.1.1.ebuild b/net-analyzer/nagios-core/nagios-core-4.1.1-r1.ebuild
index 69a4faa79144..748ef0e8ecdf 100644
--- a/net-analyzer/nagios-core/nagios-core-4.1.1.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-4.1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -92,9 +92,9 @@ src_prepare(){
#
# http://tracker.nagios.org/view.php?id=651
#
- # Gentoo bug #388321.
+ # Gentoo bugs #388321 and #581148.
#
- epatch "${FILESDIR}"/use-INSTALL-to-install-themes.patch
+ epatch "${FILESDIR}"/use-INSTALL-to-install-themes-r1.patch
}
src_configure() {