summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 04:55:11 +0000
committerSam James <sam@gentoo.org>2021-03-04 04:55:11 +0000
commitaa8f5b8468677803bbfe9e93a7e35c4cd4eeb5de (patch)
tree69eac79e25718f363094a0ccda2d215ccf8e88c3 /net-analyzer
parentnet-analyzer/wireshark: rename live ebuild (diff)
downloadgentoo-aa8f5b8468677803bbfe9e93a7e35c4cd4eeb5de.tar.gz
gentoo-aa8f5b8468677803bbfe9e93a7e35c4cd4eeb5de.tar.bz2
gentoo-aa8f5b8468677803bbfe9e93a7e35c4cd4eeb5de.zip
net-analyzer/nmap: remove old
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/nmap-7.80-r1.ebuild129
-rw-r--r--net-analyzer/nmap/nmap-7.91.ebuild108
2 files changed, 0 insertions, 237 deletions
diff --git a/net-analyzer/nmap/nmap-7.80-r1.ebuild b/net-analyzer/nmap/nmap-7.80-r1.ebuild
deleted file mode 100644
index 41fbe9aca700..000000000000
--- a/net-analyzer/nmap/nmap-7.80-r1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools desktop flag-o-matic toolchain-funcs
-
-DESCRIPTION="Network exploration tool and security / port scanner"
-HOMEPAGE="https://nmap.org/"
-SRC_URI="https://nmap.org/dist/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="ipv6 libressl libssh2 ncat nmap-update nping +nse ssl system-lua"
-REQUIRED_USE="system-lua? ( nse )"
-
-RDEPEND="
- dev-libs/liblinear:=
- dev-libs/libpcre
- net-libs/libpcap
- libssh2? (
- net-libs/libssh2[zlib]
- sys-libs/zlib
- )
- nmap-update? (
- dev-libs/apr
- dev-vcs/subversion
- )
- nse? ( sys-libs/zlib )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- )
- system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.10_beta1-string.patch
- "${FILESDIR}"/${PN}-5.21-python.patch
- "${FILESDIR}"/${PN}-6.46-uninstaller.patch
- "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
- "${FILESDIR}"/${PN}-7.25-no-FORTIFY_SOURCE.patch
- "${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
- "${FILESDIR}"/${PN}-7.25-libpcre.patch
- "${FILESDIR}"/${PN}-7.31-libnl.patch
- "${FILESDIR}"/${PN}-7.80-ac-config-subdirs.patch
-)
-
-src_prepare() {
- rm -r liblinear/ libpcap/ libpcre/ libssh2/ libz/ || die
-
- cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
-
- default
-
- sed -i \
- -e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
- Makefile.in || die
- # Fix desktop files wrt bug #432714
- sed -i \
- -e 's|^Categories=.*|Categories=Network;System;Security;|g' \
- zenmap/install_scripts/unix/zenmap-root.desktop \
- zenmap/install_scripts/unix/zenmap.desktop || die
-
- cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
-
- eautoreconf
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # we need the original for a Darwin-specific fix, bug #604432
- mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
- fi
-}
-
-src_configure() {
- # The bundled libdnet is incompatible with the version available in the
- # tree, so we cannot use the system library here.
- econf \
- $(use_enable ipv6) \
- $(use_with libssh2) \
- $(use_with ncat) \
- --without-ndiff \
- $(use_with nmap-update) \
- $(use_with nping) \
- $(use_with ssl openssl) \
- --without-zenmap \
- $(usex libssh2 --with-zlib) \
- $(usex nse --with-zlib) \
- $(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
- --cache-file="${S}"/config.cache \
- --with-libdnet=included \
- --with-pcre=/usr
- # Commented out because configure does weird things
- # --with-liblinear=/usr \
-}
-
-src_compile() {
- local directory
- for directory in . libnetutil nsock/src \
- $(usex ncat ncat '') \
- $(usex nmap-update nmap-update '') \
- $(usex nping nping '')
- do
- emake -C "${directory}" makefile.dep
- done
-
- emake \
- AR=$(tc-getAR) \
- RANLIB=$(tc-getRANLIB)
-}
-
-src_install() {
- LC_ALL=C emake -j1 \
- DESTDIR="${D}" \
- STRIP=: \
- nmapdatadir="${EPREFIX}"/usr/share/nmap \
- install
- if use nmap-update;then
- LC_ALL=C emake -j1 \
- -C nmap-update \
- DESTDIR="${D}" \
- STRIP=: \
- nmapdatadir="${EPREFIX}"/usr/share/nmap \
- install
- fi
-
- dodoc CHANGELOG HACKING docs/README docs/*.txt
-}
diff --git a/net-analyzer/nmap/nmap-7.91.ebuild b/net-analyzer/nmap/nmap-7.91.ebuild
deleted file mode 100644
index 006cbe5ee03c..000000000000
--- a/net-analyzer/nmap/nmap-7.91.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools flag-o-matic toolchain-funcs
-
-DESCRIPTION="Network exploration tool and security / port scanner"
-HOMEPAGE="https://nmap.org/"
-SRC_URI="https://nmap.org/dist/${P}.tar.bz2"
-
-LICENSE="NPSL"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="ipv6 libressl libssh2 ncat nping +nse ssl system-lua"
-REQUIRED_USE="system-lua? ( nse )"
-
-RDEPEND="
- dev-libs/liblinear:=
- dev-libs/libpcre
- net-libs/libpcap
- libssh2? (
- net-libs/libssh2[zlib]
- sys-libs/zlib
- )
- nse? ( sys-libs/zlib )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- )
- system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.10_beta1-string.patch
- "${FILESDIR}"/${PN}-5.21-python.patch
- "${FILESDIR}"/${PN}-6.46-uninstaller.patch
- "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
- "${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
- "${FILESDIR}"/${PN}-7.25-libpcre.patch
- "${FILESDIR}"/${PN}-7.31-libnl.patch
- "${FILESDIR}"/${PN}-7.80-ac-config-subdirs.patch
- "${FILESDIR}"/${PN}-7.91-no-FORTIFY_SOURCE.patch
-)
-
-src_prepare() {
- rm -r liblinear/ libpcap/ libpcre/ libssh2/ libz/ || die
-
- cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
-
- default
-
- sed -i \
- -e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
- Makefile.in || die
-
- cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
-
- eautoreconf
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # we need the original for a Darwin-specific fix, bug #604432
- mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
- fi
-}
-
-src_configure() {
- # The bundled libdnet is incompatible with the version available in the
- # tree, so we cannot use the system library here.
- econf \
- $(use_enable ipv6) \
- $(use_with libssh2) \
- $(use_with ncat) \
- $(use_with nping) \
- $(use_with ssl openssl) \
- $(usex libssh2 --with-zlib) \
- $(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
- $(usex nse --with-zlib) \
- --cache-file="${S}"/config.cache \
- --with-libdnet=included \
- --with-pcre=/usr \
- --without-ndiff \
- --without-zenmap
-}
-
-src_compile() {
- local directory
- for directory in . libnetutil nsock/src \
- $(usex ncat ncat '') \
- $(usex nping nping '')
- do
- emake -C "${directory}" makefile.dep
- done
-
- emake \
- AR=$(tc-getAR) \
- RANLIB=$(tc-getRANLIB)
-}
-
-src_install() {
- LC_ALL=C emake -j1 \
- DESTDIR="${D}" \
- STRIP=: \
- nmapdatadir="${EPREFIX}"/usr/share/nmap \
- install
-
- dodoc CHANGELOG HACKING docs/README docs/*.txt
-}