summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-01 08:36:08 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-01 08:36:51 +0200
commitac5aed68fd7b5cf55b1a22cfa417b65ae29c400c (patch)
tree4dd3b356d59474ad78d9b06b2fea09364b8213de /net-analyzer
parentpackage.mask: Last rite app-text/fbless (diff)
downloadgentoo-ac5aed68fd7b5cf55b1a22cfa417b65ae29c400c.tar.gz
gentoo-ac5aed68fd7b5cf55b1a22cfa417b65ae29c400c.tar.bz2
gentoo-ac5aed68fd7b5cf55b1a22cfa417b65ae29c400c.zip
net-analyzer/trafshow: Fix building against libpcap-1.10.0
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/trafshow/files/trafshow-5.2.3-pcap_init.patch29
-rw-r--r--net-analyzer/trafshow/trafshow-5.2.3-r1.ebuild45
2 files changed, 74 insertions, 0 deletions
diff --git a/net-analyzer/trafshow/files/trafshow-5.2.3-pcap_init.patch b/net-analyzer/trafshow/files/trafshow-5.2.3-pcap_init.patch
new file mode 100644
index 000000000000..046795a58328
--- /dev/null
+++ b/net-analyzer/trafshow/files/trafshow-5.2.3-pcap_init.patch
@@ -0,0 +1,29 @@
+--- a/trafshow.c
++++ b/trafshow.c
+@@ -58,7 +58,7 @@
+ static void vers();
+ static void usage();
+ static pcap_if_t *pcap_matchdev(pcap_if_t *dp, const char *name);
+-static int pcap_init(PCAP_HANDLER **ph_list, pcap_if_t *dp);
++static int ts_pcap_init(PCAP_HANDLER **ph_list, pcap_if_t *dp);
+ static void *pcap_feed(void *arg); /* PCAP_HANDLER *ph */
+ #ifdef HAVE_PCAP_GET_SELECTABLE_FD
+ static void *pcap_feed2(void *arg); /* PCAP_HANDLER *ph */
+@@ -172,7 +172,7 @@
+ }
+
+ /* initialize list of pcap handlers */
+- if ((op = pcap_init(&ph_list, dev_list)) < 1) {
++ if ((op = ts_pcap_init(&ph_list, dev_list)) < 1) {
+ fprintf(stderr, "No packet capture device available (no permission?)\n");
+ exit(1);
+ }
+@@ -298,7 +298,7 @@
+ }
+
+ static int
+-pcap_init(ph_list, dp)
++ts_pcap_init(ph_list, dp)
+ PCAP_HANDLER **ph_list;
+ pcap_if_t *dp;
+ {
diff --git a/net-analyzer/trafshow/trafshow-5.2.3-r1.ebuild b/net-analyzer/trafshow/trafshow-5.2.3-r1.ebuild
new file mode 100644
index 000000000000..ce61398d05f8
--- /dev/null
+++ b/net-analyzer/trafshow/trafshow-5.2.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Full screen visualization of the network traffic"
+HOMEPAGE="http://soft.risp.ru/trafshow/index_en.shtml"
+SRC_URI="ftp://ftp.nsk.su/pub/RinetSoftware/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="slang"
+
+DEPEND="
+ net-libs/libpcap
+ !slang? ( sys-libs/ncurses )
+ slang? ( >=sys-libs/slang-1.4 )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-pcap_init.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+ cat /usr/share/aclocal/pkg.m4 >> aclocal.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ if ! use slang; then
+ # No command-line option so pre-cache instead
+ export ac_cv_have_curses=ncurses
+ export LIBS=-lncurses
+ fi
+
+ default
+}