summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-02-09 23:11:44 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-02-10 00:26:32 +0100
commitb3b5cc00818b14a215586a2643eccdb5aefe5257 (patch)
treec3d3e211d216b16d00551bd6ccf448b1c779e7df /net-analyzer
parentdev-python/browser-cookie3: new package, add 0.17.0 (diff)
downloadgentoo-b3b5cc00818b14a215586a2643eccdb5aefe5257.tar.gz
gentoo-b3b5cc00818b14a215586a2643eccdb5aefe5257.tar.bz2
gentoo-b3b5cc00818b14a215586a2643eccdb5aefe5257.zip
net-analyzer/wapiti: drop 9999
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wapiti/wapiti-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-analyzer/wapiti/wapiti-9999.ebuild b/net-analyzer/wapiti/wapiti-9999.ebuild
deleted file mode 100644
index 462342ee254f..000000000000
--- a/net-analyzer/wapiti/wapiti-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE='xml(+)'
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Web-application vulnerability scanner"
-HOMEPAGE="http://wapiti.sourceforge.net/"
-EGIT_REPO_URI="https://git.code.sf.net/p/wapiti/git wapiti-git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-# Requires httpx-ntlm (to package)
-#IUSE="ntlm"
-IUSE="test"
-
-# httpx requires brotli and socks, so depending on
-# dev-python/socksio and dev-python/brotlicffi
-RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
- dev-python/socksio[${PYTHON_USEDEP}]
- dev-python/tld[${PYTHON_USEDEP}]
- dev-python/yaswfp[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-# Tests also require unpackaged respx
-BDEPEND+=" test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )"
-# Many tests require execution of local test php server
-RESTRICT="test"
-
-python_prepare_all() {
- sed -e 's/"pytest-runner"//' \
- -e "/DOC_DIR =/s/wapiti/${PF}/" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}