summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2016-02-19 21:23:50 +0100
committerSlawomir Lis <slis@gentoo.org>2016-02-19 21:23:50 +0100
commitb78db6c8dcc6826a4f544e7269faec38f90dcd49 (patch)
treee5d5d3ec602f3d5de9244715823666e7cf7d7265 /net-analyzer
parentdev-java/xp: Switch to java-pkg-simple. (diff)
downloadgentoo-b78db6c8dcc6826a4f544e7269faec38f90dcd49.tar.gz
gentoo-b78db6c8dcc6826a4f544e7269faec38f90dcd49.tar.bz2
gentoo-b78db6c8dcc6826a4f544e7269faec38f90dcd49.zip
useflag to use libhtp instead of bundled one (#575144)
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/suricata/metadata.xml1
-rw-r--r--net-analyzer/suricata/suricata-2.0.11.ebuild13
2 files changed, 7 insertions, 7 deletions
diff --git a/net-analyzer/suricata/metadata.xml b/net-analyzer/suricata/metadata.xml
index 0f80bed1d8da..517666e56cef 100644
--- a/net-analyzer/suricata/metadata.xml
+++ b/net-analyzer/suricata/metadata.xml
@@ -13,5 +13,6 @@
<flag name="nflog">Enable libnetfilter_log support</flag>
<flag name="nfqueue">Enable AF_PACKET support</flag>
<flag name="rules">Enable AF_PACKET support</flag>
+ <flag name="system-htp">Use net-libs/libhtp instead of bundled one</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/suricata/suricata-2.0.11.ebuild b/net-analyzer/suricata/suricata-2.0.11.ebuild
index 250c663dbd21..0323836a2407 100644
--- a/net-analyzer/suricata/suricata-2.0.11.ebuild
+++ b/net-analyzer/suricata/suricata-2.0.11.ebuild
@@ -13,7 +13,7 @@ SRC_URI="http://www.openinfosecfoundation.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+af-packet control-socket cuda debug +detection geoip hardened lua luajit nflog +nfqueue +rules test"
+IUSE="+af-packet control-socket cuda debug +detection geoip hardened lua luajit nflog +nfqueue +rules system-htp test"
DEPEND="
>=dev-libs/jansson-2.2
@@ -31,11 +31,11 @@ DEPEND="
luajit? ( dev-lang/luajit:* )
nflog? ( net-libs/libnetfilter_log )
nfqueue? ( net-libs/libnetfilter_queue )
+ system-htp? ( >=net-libs/libhtp-0.5.18 )
"
# #446814
# prelude? ( dev-libs/libprelude )
# pfring? ( sys-process/numactl net-libs/pf_ring)
-# system-htp? ( >=net-analyzer/htp-0.5.5 )
RDEPEND="${DEPEND}"
pkg_setup() {
@@ -85,10 +85,9 @@ src_configure() {
# if use prelude ; then
# myeconfargs+=( $(use_enable prelude) )
# fi
- # htp not added into portage yet
-# if use system-htp ; then
-# myeconfargs+=( $(use_enable system-htp non-bundled-htp) )
-# fi
+ if use system-htp ; then
+ myeconfargs+=( $(use_enable system-htp non-bundled-htp) )
+ fi
if use lua ; then
myeconfargs+=( $(use_enable lua) )
fi
@@ -117,4 +116,4 @@ src_install() {
dodir "/var/log/${PN}"
fowners -R ${PN}: "/var/lib/${PN}" "/var/log/${PN}" "/etc/${PN}"
fperms 750 "/var/lib/${PN}" "/var/log/${PN}" "/etc/${PN}"
-} \ No newline at end of file
+}