summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaul E Rangel <rrangel@chromium.org>2023-08-15 10:53:30 -0600
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-25 15:55:02 +0300
commitc5bc79e914e90097efade012df40509baf5cf5f2 (patch)
tree901950ff420873c6a038124d3eda180487d68158 /net-analyzer
parentgames-util/cartridges: Stabilize 2.2.1 amd64, #914654 (diff)
downloadgentoo-c5bc79e914e90097efade012df40509baf5cf5f2.tar.gz
gentoo-c5bc79e914e90097efade012df40509baf5cf5f2.tar.bz2
gentoo-c5bc79e914e90097efade012df40509baf5cf5f2.zip
net-analyzer/netperf: Fix dependencies
The acct- dependencies should be BDEPEND instead of DEPEND. We also need gnuconfig so that the config.sub will get patched with `econf`. Otherwise we get the following error: ``` configure: loading site script /usr/share/config.site configure: loading site script /usr/share/crossdev/include/site/linux configure: loading site script /usr/share/crossdev/include/site/linux-gnu checking build system type... x86_64-pc-linux-gnu checking host system type... Invalid configuration `aarch64-cros-linux-gnu': machine `aarch64-cros' not recognized configure: error: /bin/sh ./config.sub aarch64-cros-linux-gnu failed ``` vs a good run that has gnuconfig installed prints the following: ``` >>> Configuring source in /build/arm64-generic/tmp/portage/net-analyzer/netperf-2.7.0-r4/work/netperf-2.7.0 ... * econf: updating netperf-2.7.0/config.guess with /usr/share/gnuconfig/config.guess * econf: updating netperf-2.7.0/config.sub with /usr/share/gnuconfig/config.sub ``` Signed-off-by: Raul E Rangel <rrangel@chromium.org> Closes: https://github.com/gentoo/gentoo/pull/32326 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netperf/netperf-2.7.0-r5.ebuild (renamed from net-analyzer/netperf/netperf-2.7.0-r4.ebuild)7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-analyzer/netperf/netperf-2.7.0-r4.ebuild b/net-analyzer/netperf/netperf-2.7.0-r5.ebuild
index f2cbe9c445a8..b66c8514fe1b 100644
--- a/net-analyzer/netperf/netperf-2.7.0-r4.ebuild
+++ b/net-analyzer/netperf/netperf-2.7.0-r5.ebuild
@@ -14,11 +14,14 @@ LICENSE="netperf"
SLOT="0"
IUSE="demo sctp"
-DEPEND="
+RDEPEND="
acct-group/netperf
acct-user/netperf
"
-RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/gnuconfig
+ ${RDEPEND}
+"
PATCHES=(
"${FILESDIR}"/${PN}-fix-scripts.patch