summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-24 09:54:35 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-24 09:55:36 +0200
commitd1c4217456364c563e6ff53b47e642a81721e24c (patch)
treeb46b4a00f1090abe19e07c7711e9aeda73b19922 /net-analyzer
parentmail-client/balsa: bump to 2.6.1 (diff)
downloadgentoo-d1c4217456364c563e6ff53b47e642a81721e24c.tar.gz
gentoo-d1c4217456364c563e6ff53b47e642a81721e24c.tar.bz2
gentoo-d1c4217456364c563e6ff53b47e642a81721e24c.zip
net-analyzer/tcpdump: Do actually use that patch from January
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Closes: https://bugs.gentoo.org/731192 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild19
-rw-r--r--net-analyzer/tcpdump/tcpdump-9999.ebuild18
2 files changed, 20 insertions, 17 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild b/net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild
index 8374b080d4e2..e23d799be4ba 100644
--- a/net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-4.9.3-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic toolchain-funcs user
+inherit autotools user
DESCRIPTION="A Tool for network monitoring and data acquisition"
HOMEPAGE="
@@ -20,8 +20,8 @@ IUSE="+drop-root libressl smi ssl samba suid test"
RESTRICT="!test? ( test )"
RDEPEND="
- drop-root? ( sys-libs/libcap-ng )
net-libs/libpcap
+ drop-root? ( sys-libs/libcap-ng )
smi? ( net-libs/libsmi )
ssl? (
!libressl? ( >=dev-libs/openssl-0.9.6m:0= )
@@ -30,12 +30,14 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- drop-root? ( virtual/pkgconfig )
test? (
>=net-libs/libpcap-1.9.1
dev-lang/perl
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-libdir.patch
+)
pkg_setup() {
if use drop-root || use suid; then
@@ -44,14 +46,15 @@ pkg_setup() {
fi
}
-src_configure() {
- if use drop-root; then
- append-cppflags -DHAVE_CAP_NG_H
- export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
- fi
+src_prepare() {
+ default
+ eautoreconf
+}
+src_configure() {
econf \
$(use_enable samba smb) \
+ $(use_with drop-root cap-ng) \
$(use_with drop-root chroot '') \
$(use_with smi) \
$(use_with ssl crypto "${ESYSROOT}/usr") \
diff --git a/net-analyzer/tcpdump/tcpdump-9999.ebuild b/net-analyzer/tcpdump/tcpdump-9999.ebuild
index ac642f4be7b4..b0c0a0baa597 100644
--- a/net-analyzer/tcpdump/tcpdump-9999.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic toolchain-funcs user
+inherit autotools git-r3 user
DESCRIPTION="A Tool for network monitoring and data acquisition"
EGIT_REPO_URI="https://github.com/the-tcpdump-group/tcpdump"
@@ -32,9 +32,11 @@ RDEPEND="
libressl? ( dev-libs/libressl:= )
)
"
+BDEPEND="
+ drop-root? ( virtual/pkgconfig )
+"
DEPEND="
${RDEPEND}
- drop-root? ( virtual/pkgconfig )
test? (
>=net-libs/libpcap-1.9.1
dev-lang/perl
@@ -52,22 +54,20 @@ pkg_setup() {
}
src_prepare() {
- default
-
sed -i -e '/^eapon1/d;' tests/TESTLIST || die
# bug 630394
sed -i -e '/^nbns-valgrind/d' tests/TESTLIST || die
+
+ default
+
+ eautoreconf
}
src_configure() {
- if use drop-root; then
- append-cppflags -DHAVE_CAP_NG_H
- export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
- fi
-
econf \
$(use_enable samba smb) \
+ $(use_with drop-root cap-ng) \
$(use_with drop-root chroot '') \
$(use_with smi) \
$(use_with ssl crypto "${ESYSROOT}/usr") \