summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-01 07:37:49 +0100
committerSam James <sam@gentoo.org>2021-07-01 07:45:19 +0100
commitd4a1ca5040f7fde084492d0417e27c23d8ce9777 (patch)
tree476961118775a7c16434b069a26d95dea7ee21e0 /net-analyzer
parentapp-text/kramdown-rfc2629: initial import (migrated from ::guru) (diff)
downloadgentoo-d4a1ca5040f7fde084492d0417e27c23d8ce9777.tar.gz
gentoo-d4a1ca5040f7fde084492d0417e27c23d8ce9777.tar.bz2
gentoo-d4a1ca5040f7fde084492d0417e27c23d8ce9777.zip
net-analyzer/arping: add 2.22
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/arping/Manifest1
-rw-r--r--net-analyzer/arping/arping-2.22.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/arping/Manifest b/net-analyzer/arping/Manifest
index 19b7129a26b1..fb1a565d27c9 100644
--- a/net-analyzer/arping/Manifest
+++ b/net-analyzer/arping/Manifest
@@ -1 +1,2 @@
DIST arping-2.21.tar.gz 50067 BLAKE2B 67b76cc48e9717117dbf43702df7f422634ed40196ec44d273a773610618922ddf7de47ffdf32cb7296db1dbce0a696c57b7992e6ad11f6fddf52a16212154fc SHA512 e976ce1a3ec0e4f57bbded09c6a07934e21df66ce7931422c420f5335dafcd88968f03ba6987d192dcdf51cca89180c86337aff50806713c7b04cb13e3e83504
+DIST arping-2.22.tar.gz 50152 BLAKE2B 2215773b922219537339550e8034bb6eca82974469ebd0e399c73bd259ef4ff7a4510d9a5ff108cef3dac492477c54fc2517c2dfd4035158d0269f03c0e2a0b5 SHA512 0b36fff2c14c1ff89453ba63eea04de3343fcb19da7dbc1c8749bc926e441c54915cd628d54171d449e66e92663e31f12e057c30a80cd49c4412650e2cd00ef3
diff --git a/net-analyzer/arping/arping-2.22.ebuild b/net-analyzer/arping/arping-2.22.ebuild
new file mode 100644
index 000000000000..1df1402f5eaa
--- /dev/null
+++ b/net-analyzer/arping/arping-2.22.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fcaps
+
+DESCRIPTION="A utility to see if a specific IP is taken and what MAC owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+ !net-misc/iputils[arping(+)]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-libs/check
+ dev-python/subunit
+ )
+"
+
+FILECAPS=( cap_net_raw usr/sbin/arping )
+
+src_prepare() {
+ default
+ eautoreconf
+}