summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-03 22:38:40 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-03 23:36:03 +0200
commitd53ba500ec443481336ab1c3fa9ee5da74efc077 (patch)
tree35ed0eb1eeaa7a4e9c2391c5c5ca7ebead02395c /net-analyzer
parentdev-python/socketio-client: Version bump to 0.7.2 (diff)
downloadgentoo-d53ba500ec443481336ab1c3fa9ee5da74efc077.tar.gz
gentoo-d53ba500ec443481336ab1c3fa9ee5da74efc077.tar.bz2
gentoo-d53ba500ec443481336ab1c3fa9ee5da74efc077.zip
net-analyzer/cacti-spine: Version 1.2.12
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.12.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 8efe327dc0db..69b761171ea4 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1 +1,2 @@
DIST cacti-spine-1.2.11.tar.gz 107495 BLAKE2B faa2356e374f392565d3a1fed446527bd5be9cf63ec1b286e0e6069503b80fea9042d367f087f05ff5660a0fb647a2d2478c6f25a557b8aec821a151af2a7f02 SHA512 6c7dd2c4b35040cce58714e1b238b473d42465327cde469cb09c304d51fe74b0731ec4ed4d70321c092d6efd4eac6ab375140beb5d552fcf7ad4286713a4f22b
+DIST cacti-spine-1.2.12.tar.gz 107512 BLAKE2B 1ced87c30d26d524ce9c98508cfee42dfccceac9e68662fbf31e257ebb8990bfd4935a735554ba3153f8382ada1fea86fb4712811857a09a49bec609a41aae5b SHA512 382a456bc64f4bfd56db8e6fcc2e626d66d529bbb6bfa34210053e64f9b61ae1376c9a4870402e7ccb069c20f91a85dbf5b4ec72826a1f3d70f2e6900accc0c3
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.12.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.12.ebuild
new file mode 100644
index 000000000000..a5c1da23c064
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}