summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-10-20 10:31:09 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-10-20 10:34:13 -0500
commitd945921ecd56547100ec24d9d6a353c0adc804b2 (patch)
tree1ffd48cee37e5ffc3d5e7176e6985a6f121ee039 /net-analyzer
parentmedia-sound/xwax: removed obsolete 1.7-r1 (diff)
downloadgentoo-d945921ecd56547100ec24d9d6a353c0adc804b2.tar.gz
gentoo-d945921ecd56547100ec24d9d6a353c0adc804b2.tar.bz2
gentoo-d945921ecd56547100ec24d9d6a353c0adc804b2.zip
net-analyzer/icinga2: clean up 2.13.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga2/Manifest1
-rw-r--r--net-analyzer/icinga2/icinga2-2.13.0.ebuild147
2 files changed, 0 insertions, 148 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index f159984d9176..0743badb86df 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1,3 +1,2 @@
DIST icinga2-2.12.4.tar.gz 7535804 BLAKE2B 495a53fc0887ff2e1b5e058c52af63c155da600b4c82e38653a56c4b1dab497ef477254b19727c6c366b48c41a052b68c9910cb4bc4782605612a3d63ccf646c SHA512 3a817eb6f1be256f6eca5136e3d74c49e1cc2a7af382a906abebc6d573579e755decf72bfce62fad48f9c5a37fe6bc304c5849d1008ab7ce4939213f720ab37b
-DIST icinga2-2.13.0.tar.gz 7584525 BLAKE2B 94c08030e508c35d610c12e9855015da35e4dd6a67614bc44ab5605ba61f9f3f9ddc4fec98be8534ae2e84d1d1c1065295b872c6a060a36e821f929c04a90172 SHA512 a3eb0166bb2851a7e6e795fc541b535db3ac2d8d9c2e4e72caf0472e54ac0ef110ea97a1c1c208b97c2b99e1ec51919a378bba68b21e770786074dcb1af4bd26
DIST icinga2-2.13.1.tar.gz 7585070 BLAKE2B 5a81d627728f8afb0c19761972d45606db246c132dfeb92d2fb32479631add8aaeb1d0dea66f354d3638ca346a3e8bcc266e8397e5246f984566f75c2b5e8003 SHA512 450df3ee36457006c78ca244331d111f65642ba5e232be28e60f189de998f5bb8ed70f2e1d46ea61374ae7bd6a5cf950e487bada1c7af7064970a149cc86baa7
diff --git a/net-analyzer/icinga2/icinga2-2.13.0.ebuild b/net-analyzer/icinga2/icinga2-2.13.0.ebuild
deleted file mode 100644
index de80eb55dfc4..000000000000
--- a/net-analyzer/icinga2/icinga2-2.13.0.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
-fi
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="https://icinga.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="console jumbo-build lto mail mariadb minimal +mysql nano-syntax +plugins postgres systemd +vim-syntax"
-
-# Add accounts to DEPEND because of fowners in src_install
-DEPEND="
- dev-libs/openssl:0=
- >=dev-libs/boost-1.66.0:=[context]
- console? ( dev-libs/libedit )
- mariadb? ( dev-db/mariadb-connector-c:= )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:= )
- dev-libs/yajl:=
- acct-user/icinga
- acct-group/icinga
- acct-group/icingacmd"
-BDEPEND="
- sys-devel/bison
- >=sys-devel/flex-2.5.35"
-RDEPEND="
- ${DEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- mail? ( virtual/mailx )
- acct-group/nagios"
-
-REQUIRED_USE="!minimal? ( || ( mariadb mysql postgres ) )"
-
-PATCHES=(
- # https://github.com/Icinga/icinga2/issues/8185#issuecomment-680875875
-)
-
-src_configure() {
- local mycmakeargs=(
- -DICINGA2_UNITY_BUILD=$(usex jumbo-build)
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DICINGA2_RUNDIR=/run
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=ON
- -DUSE_SYSTEMD=$(usex systemd)
- -DLOGROTATE_HAS_SU=ON
- -DICINGA2_LTO_BUILD=$(usex lto)
- )
- # default to off if minimal, allow the flags to be set otherwise
- if use minimal; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- -DICINGA2_WITH_PGSQL=OFF
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=$(usex postgres)
- -DICINGA2_WITH_MYSQL=$(usex mysql yes $(usex mariadb))
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- newinitd "${FILESDIR}"/icinga2.initd-3 icinga2
-
- if use mysql || use mariadb; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- fi
- if use postgres; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}/run" || die "failed to remove /run"
- rm -r "${D}/var/cache" || die "failed to remove /var/cache"
-
- fowners root:icinga /etc/icinga2
- fperms 0750 /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners -R icinga:icingacmd /var/lib/icinga2/api
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- if [[ "${PV}" != 9999 ]]; then
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${PV}" -gt "${v}"; then
- elog "DB IDO schema upgrade may be required."
- elog "https://www.icinga.com/docs/icinga2/latest/doc/16-upgrading-icinga-2/"
- fi
- done
- fi
-}