summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:56:14 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:58 +0100
commitdd153d6fcb27098585d546fe1329819f7e18f980 (patch)
treee2d7c435971038f296b837c4580ab7a49c0c9c81 /net-analyzer
parentnet-analyzer/suricata: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-dd153d6fcb27098585d546fe1329819f7e18f980.tar.gz
gentoo-dd153d6fcb27098585d546fe1329819f7e18f980.tar.bz2
gentoo-dd153d6fcb27098585d546fe1329819f7e18f980.zip
net-analyzer/vnstat: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/vnstat/vnstat-2.6-r1.ebuild4
-rw-r--r--net-analyzer/vnstat/vnstat-2.7.ebuild4
-rw-r--r--net-analyzer/vnstat/vnstat-9999.ebuild4
3 files changed, 12 insertions, 0 deletions
diff --git a/net-analyzer/vnstat/vnstat-2.6-r1.ebuild b/net-analyzer/vnstat/vnstat-2.6-r1.ebuild
index 3d37feff320b..1f52869e87aa 100644
--- a/net-analyzer/vnstat/vnstat-2.6-r1.ebuild
+++ b/net-analyzer/vnstat/vnstat-2.6-r1.ebuild
@@ -77,3 +77,7 @@ src_install() {
newdoc INSTALL README.setup
dodoc CHANGES README UPGRADE FAQ examples/vnstat.cgi
}
+
+pkg_postinst() {
+ tmpfiles_process vnstatd.conf
+}
diff --git a/net-analyzer/vnstat/vnstat-2.7.ebuild b/net-analyzer/vnstat/vnstat-2.7.ebuild
index 3582e9086840..a950ea587315 100644
--- a/net-analyzer/vnstat/vnstat-2.7.ebuild
+++ b/net-analyzer/vnstat/vnstat-2.7.ebuild
@@ -80,3 +80,7 @@ src_install() {
newdoc INSTALL README.setup
dodoc CHANGES README UPGRADE FAQ examples/vnstat.cgi
}
+
+pkg_postinst() {
+ tmpfiles_process vnstatd.conf
+}
diff --git a/net-analyzer/vnstat/vnstat-9999.ebuild b/net-analyzer/vnstat/vnstat-9999.ebuild
index 189549001483..50a581a0103a 100644
--- a/net-analyzer/vnstat/vnstat-9999.ebuild
+++ b/net-analyzer/vnstat/vnstat-9999.ebuild
@@ -80,3 +80,7 @@ src_install() {
newdoc INSTALL README.setup
dodoc CHANGES README UPGRADE FAQ examples/vnstat.cgi
}
+
+pkg_postinst() {
+ tmpfiles_process vnstatd.conf
+}