summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-07-29 18:48:56 +0000
committerMichał Górny <mgorny@gentoo.org>2020-08-27 11:20:14 +0200
commite327358f85ed6359cedb374b8b14d9af544ad447 (patch)
treef73d68c7af3916b5ee30dd06f7a934860ec55091 /net-analyzer
parentdev-ros/test_roscpp: serialize tests (diff)
downloadgentoo-e327358f85ed6359cedb374b8b14d9af544ad447.tar.gz
gentoo-e327358f85ed6359cedb374b8b14d9af544ad447.tar.bz2
gentoo-e327358f85ed6359cedb374b8b14d9af544ad447.zip
net-analyzer/linkchecker: sync live ebuild
Bug: https://bugs.gentoo.org/712958 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/linkchecker-9999.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/net-analyzer/linkchecker/linkchecker-9999.ebuild b/net-analyzer/linkchecker/linkchecker-9999.ebuild
index 32272ea2e2c4..96c44d5d7cb4 100644
--- a/net-analyzer/linkchecker/linkchecker-9999.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9999.ebuild
@@ -1,31 +1,36 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..8} )
PYTHON_REQ_USE="sqlite?"
-EGIT_REPO_URI="https://github.com/linkcheck/linkchecker.git"
-inherit bash-completion-r1 distutils-r1 eutils git-r3
+inherit bash-completion-r1 distutils-r1 eutils
DESCRIPTION="Check websites for broken links"
HOMEPAGE="https://github.com/linkcheck/linkchecker"
-SRC_URI=""
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/linkcheck/linkchecker.git"
+ inherit git-r3
+else
+ SRC_URI=""
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="sqlite"
+# requires py2 only libs
+RESTRICT="test"
RDEPEND="
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
dev-python/dnspython[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
"
-DEPEND=""
-
-RESTRICT="test"
python_prepare_all() {
local PATCHES=(
@@ -36,16 +41,12 @@ python_prepare_all() {
}
python_install_all() {
- DOCS=(
+ local DOCS=(
doc/changelog.txt
- doc/development.mdwn
- doc/python3.txt
doc/upgrading.txt
)
distutils-r1_python_install_all
- rm "${ED}"/usr/share/applications/linkchecker.desktop || die
-
newbashcomp config/linkchecker-completion ${PN}
}
@@ -53,4 +54,5 @@ pkg_postinst() {
optfeature "bash-completion support" dev-python/argcomplete[${PYTHON_USEDEP}]
optfeature "Virus scanning" app-antivirus/clamav
optfeature "Geo IP support" dev-python/geoip-python[${PYTHON_USEDEP}]
+ optfeature "GNOME proxy settings support" dev-python/pygobject[${PYTHON_USEDEP}]
}