summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2021-08-19 10:23:37 +0200
committerSam James <sam@gentoo.org>2021-08-22 04:16:59 +0100
commit1f2061c02b0ce09b03b37235263ac760b12ed95b (patch)
treede459bb292f38ff2971e0f7f31c96e89add7dde5 /net-dialup/freeradius-client/freeradius-client-1.1.7-r2.ebuild
parentnet-mail/popa3d: add missing libcrypt dependency (diff)
downloadgentoo-1f2061c02b0ce09b03b37235263ac760b12ed95b.tar.gz
gentoo-1f2061c02b0ce09b03b37235263ac760b12ed95b.tar.bz2
gentoo-1f2061c02b0ce09b03b37235263ac760b12ed95b.zip
net-dialup/freeradius-client: Adding virtual/libcrypt as dependency
Closes: https://bugs.gentoo.org/808981 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr> Closes: https://github.com/gentoo/gentoo/pull/22041 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dialup/freeradius-client/freeradius-client-1.1.7-r2.ebuild')
-rw-r--r--net-dialup/freeradius-client/freeradius-client-1.1.7-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-dialup/freeradius-client/freeradius-client-1.1.7-r2.ebuild b/net-dialup/freeradius-client/freeradius-client-1.1.7-r2.ebuild
new file mode 100644
index 000000000000..447e44887dd1
--- /dev/null
+++ b/net-dialup/freeradius-client/freeradius-client-1.1.7-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="FreeRADIUS Client framework"
+HOMEPAGE="https://wiki.freeradius.org/project/Radiusclient"
+SRC_URI="ftp://ftp.freeradius.org/pub/freeradius/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+
+IUSE="scp shadow static-libs"
+
+DEPEND="
+ !net-dialup/radiusclient-ng
+ virtual/libcrypt:=
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ BUGS doc/{ChangeLog,login.example,release-method.txt,instop.html}
+ README.{radexample,rst}
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.7-ar-configure.in.patch"
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die \
+ "Renaming configure.in to configure.ac failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable scp)
+ $(use_enable shadow)
+ --with-secure-path
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newdoc doc/README README.login.example
+
+ use static-libs || \
+ find "${ED}" -name '*.a' -delete
+}