summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/intel-536ep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/intel-536ep')
-rw-r--r--net-dialup/intel-536ep/Manifest1
-rw-r--r--net-dialup/intel-536ep/files/intel536ep.confd5
-rw-r--r--net-dialup/intel-536ep/files/intel536ep.initd37
-rw-r--r--net-dialup/intel-536ep/intel-536ep-4.71.ebuild45
-rw-r--r--net-dialup/intel-536ep/metadata.xml6
5 files changed, 94 insertions, 0 deletions
diff --git a/net-dialup/intel-536ep/Manifest b/net-dialup/intel-536ep/Manifest
new file mode 100644
index 000000000000..298d3714d641
--- /dev/null
+++ b/net-dialup/intel-536ep/Manifest
@@ -0,0 +1 @@
+DIST intel-536ep-4.71.tgz 487685 RMD160 d85ac0e36251ba9a90bac4e822f36fa8f1a1ff70 SHA1 b7980b65840184fbcb8f3d3ccdf77ff7f84d7aa6 SHA256 3843f764f82877f8300fd48ba6f7b3b9016cfd95c27633a7eb26da19c542a9db
diff --git a/net-dialup/intel-536ep/files/intel536ep.confd b/net-dialup/intel-536ep/files/intel536ep.confd
new file mode 100644
index 000000000000..de5f8b19c9ea
--- /dev/null
+++ b/net-dialup/intel-536ep/files/intel536ep.confd
@@ -0,0 +1,5 @@
+#Node name of the device
+DEV_NAME=536ep
+
+#Which group will have the permission to use this modem
+DEV_GROUP=tty
diff --git a/net-dialup/intel-536ep/files/intel536ep.initd b/net-dialup/intel-536ep/files/intel536ep.initd
new file mode 100644
index 000000000000..53b9049fbf71
--- /dev/null
+++ b/net-dialup/intel-536ep/files/intel536ep.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+#NB: Config is in /etc/conf.d/intel536ep
+
+depend() {
+ need localmount modules
+}
+
+start() {
+ local device=${DEV_NAME:-536ep}
+
+ ebegin "Starting Intel 536EP modem"
+
+ if ! modprobe -f Intel536 &>/dev/null ; then
+ eend $?
+ eerror "Failed to load Intel536 module"
+ return 1
+ fi
+
+ major=`cat /proc/devices | awk "\\$2==\"$device\" {print \\$1}"`
+ [ -e "/dev/$device" ] && rm -f /dev/$device
+ mknod -m 0660 /dev/$device c $major 1
+ chgrp ${DEV_GROUP:-tty} /dev/$device
+ [ -e /dev/modem ] || ln -sf $device /dev/modem
+
+ start-stop-daemon --start --quiet --background --make-pidfile --pidfile /var/run/hamregistry.pid --exec /usr/sbin/hamregistry
+ eend ${?}
+}
+
+stop () {
+ ebegin "Stopping Intel 536EP modem"
+ start-stop-daemon --stop --quiet --pidfile /var/run/hamregistry.pid
+ eend ${?}
+}
diff --git a/net-dialup/intel-536ep/intel-536ep-4.71.ebuild b/net-dialup/intel-536ep/intel-536ep-4.71.ebuild
new file mode 100644
index 000000000000..27aca97d72ff
--- /dev/null
+++ b/net-dialup/intel-536ep/intel-536ep-4.71.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit linux-mod
+
+DESCRIPTION="Driver for Intel 536EP modem"
+HOMEPAGE="http://developer.intel.com/design/modems/products/536ep.htm"
+SRC_URI="ftp://aiedownload.intel.com/df-support/9266/eng/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+S="${WORKDIR}/Intel-536"
+MODULE_NAMES="Intel536(:${S}/coredrv)"
+
+pkg_setup() {
+ if kernel_is ge 2 6 16; then
+ eerror "This driver is not supported by kernels >= 2.6.16."
+ eerror "Please see http://bugs.gentoo.org/show_bug.cgi?id=127464 for more info."
+ die "unsupported kernel version"
+ elif kernel_is 2 4; then
+ BUILD_TARGETS="536core"
+ BUILD_PARAMS="KERNEL_SOURCE_PATH='${KV_DIR}' TARGET=TARGET_SELAH"
+ else
+ BUILD_TARGETS="536core_26"
+ BUILD_PARAMS="KERNEL_SOURCE_PATH='${KV_DIR}'"
+ fi
+
+ linux-mod_pkg_setup
+}
+
+src_install() {
+ linux-mod_src_install
+
+ #install hamregistry executable
+ exeinto /usr/sbin
+ doexe "${S}/hamregistry"
+
+ #install boot script and its config
+ newinitd "${FILESDIR}/intel536ep.initd" intel536ep
+ newconfd "${FILESDIR}/intel536ep.confd" intel536ep
+}
diff --git a/net-dialup/intel-536ep/metadata.xml b/net-dialup/intel-536ep/metadata.xml
new file mode 100644
index 000000000000..377c67c87c7a
--- /dev/null
+++ b/net-dialup/intel-536ep/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+<longdescription>Driver for Intel 536EP modem</longdescription>
+</pkgmetadata>