summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-29 19:59:35 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-29 19:59:35 +0100
commit67c2b90334f3e0309fae4880f0aa43c663c2b1ed (patch)
treed75f0ea0b6daa054c525db6ff46dc8a34cd4ab2c /net-dialup/pppconfig
parentdev-lang/go: 1.17.3 bump (diff)
downloadgentoo-67c2b90334f3e0309fae4880f0aa43c663c2b1ed.tar.gz
gentoo-67c2b90334f3e0309fae4880f0aa43c663c2b1ed.tar.bz2
gentoo-67c2b90334f3e0309fae4880f0aa43c663c2b1ed.zip
net-dialup/pppconfig: Port to EAPI 8
Closes: https://bugs.gentoo.org/819360 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-dialup/pppconfig')
-rw-r--r--net-dialup/pppconfig/pppconfig-2.3.21.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-dialup/pppconfig/pppconfig-2.3.21.ebuild b/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
index 808ccc0a705e..b2560f286d53 100644
--- a/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
+++ b/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
inherit strip-linguas
@@ -14,15 +14,16 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ppc x86"
IUSE="nls"
-RDEPEND="net-dialup/ppp
+RDEPEND="
+ net-dialup/ppp
dev-util/dialog
dev-lang/perl"
-DEPEND="nls? ( sys-devel/gettext )"
+BDEPEND="nls? ( sys-devel/gettext )"
src_prepare() {
- if use nls; then
- strip-linguas -i po/
- fi
+ default
+
+ use nls && strip-linguas -i po/
}
src_compile() {