summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-25 19:20:46 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-25 19:21:16 +0100
commitb4f502cdf61882c97a98a8c6ade065a2aa834a48 (patch)
tree5653be62ca9207b8cba391ba68b3e66bb79d268e /net-dialup/pppconfig
parentdev-scheme/chez: inherit toolchain-funcs instead of multilib (diff)
downloadgentoo-b4f502cdf61882c97a98a8c6ade065a2aa834a48.tar.gz
gentoo-b4f502cdf61882c97a98a8c6ade065a2aa834a48.tar.bz2
gentoo-b4f502cdf61882c97a98a8c6ade065a2aa834a48.zip
net-dialup/pppconfig: add 2.3.25
Bug: https://bugs.gentoo.org/819360 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-dialup/pppconfig')
-rw-r--r--net-dialup/pppconfig/Manifest1
-rw-r--r--net-dialup/pppconfig/pppconfig-2.3.25.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-dialup/pppconfig/Manifest b/net-dialup/pppconfig/Manifest
index fa1d4096af8a..d6b7dc18e928 100644
--- a/net-dialup/pppconfig/Manifest
+++ b/net-dialup/pppconfig/Manifest
@@ -1 +1,2 @@
DIST pppconfig_2.3.21.tar.gz 397243 BLAKE2B 5816d9b1e832bd0e694718960ea45c0996fa7a459f3a38e03b0021d20549b81e5a74111c03f7f485bd4dbd408b2859864a69c55858cb0a4f70283971a64192bb SHA512 e6297a6834eb806d591aee44343c6e64536e260ea8e637f3a4d4b5a752e26ae90d467ca12dd83022e071f7c2c4f111660418a6b953c4a02f5618fc54a89c2893
+DIST pppconfig_2.3.25.tar.gz 392316 BLAKE2B 7c30db92cff0c9e80e04e4e7a83ccc22e2c1380831fcbc1ebd36bc4d30044c0b32669546907318be3c43061d1ea9f44b0a471f56847e75b0470f18f1aa10bf7a SHA512 6874b93ae34edb2a0ba06a669d930f5023a3eae38b6d10a78179eb69990a8280d41ebc2049461b54b03bd19904d13d2ebb57997599ed650660d0b34c958ad977
diff --git a/net-dialup/pppconfig/pppconfig-2.3.25.ebuild b/net-dialup/pppconfig/pppconfig-2.3.25.ebuild
new file mode 100644
index 000000000000..5816bbea39c4
--- /dev/null
+++ b/net-dialup/pppconfig/pppconfig-2.3.25.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit strip-linguas
+
+DESCRIPTION="A text menu based utility for configuring ppp"
+HOMEPAGE="https://tracker.debian.org/pkg/pppconfig"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="net-dialup/ppp
+ dev-util/dialog
+ dev-lang/perl"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ if use nls; then
+ strip-linguas -i po/
+ fi
+}
+
+src_compile() {
+ default
+
+ if use nls; then
+ local lang
+ for lang in ${LINGUAS}; do
+ msgfmt -o po/${lang}.{m,p}o || die
+ done
+ fi
+}
+
+src_install() {
+ keepdir /etc/chatscripts /etc/ppp/resolv
+ dosbin 0dns-down 0dns-up dns-clean
+ newsbin pppconfig pppconfig.real
+ dosbin "${FILESDIR}/pppconfig"
+ doman man/pppconfig.8
+ dodoc debian/{copyright,changelog}
+
+ if use nls; then
+ local lang
+ for lang in ${LINGUAS}; do
+ insinto /usr/share/locale/${lang}/LC_MESSAGES
+ newins po/${lang}.mo pppconfig.mo
+ done
+ fi
+}