summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:39:51 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:39:51 +0100
commitb5c4c6c8eced1a124516a2847e39662e3e59e298 (patch)
tree53cd0f2ee977b35405171b13a3e5aec17203ed6e /net-dialup/radiusclient-ng/radiusclient-ng-0.5.6-r2.ebuild
parentnet-fs/netatalk: add missing libcrypt dependency (diff)
downloadgentoo-b5c4c6c8eced1a124516a2847e39662e3e59e298.tar.gz
gentoo-b5c4c6c8eced1a124516a2847e39662e3e59e298.tar.bz2
gentoo-b5c4c6c8eced1a124516a2847e39662e3e59e298.zip
net-dialup/radiusclient-ng: add missing libcrypt dependency
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dialup/radiusclient-ng/radiusclient-ng-0.5.6-r2.ebuild')
-rw-r--r--net-dialup/radiusclient-ng/radiusclient-ng-0.5.6-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-dialup/radiusclient-ng/radiusclient-ng-0.5.6-r2.ebuild b/net-dialup/radiusclient-ng/radiusclient-ng-0.5.6-r2.ebuild
new file mode 100644
index 000000000000..f64147e4d656
--- /dev/null
+++ b/net-dialup/radiusclient-ng/radiusclient-ng-0.5.6-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="RadiusClient NextGeneration - library for RADIUS clients"
+HOMEPAGE="https://sourceforge.net/projects/radiusclient-ng.berlios/"
+SRC_URI="mirror://sourceforge/${PN}.berlios/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+
+DEPEND="!net-dialup/radiusclient
+ !net-dialup/freeradius-client
+ virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+
+DOCS=( BUGS CHANGES README )
+HTML_DOCS=( doc/instop.html )
+
+PATCHES=(
+ "${FILESDIR}/${P}-cross-compile.patch"
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # bug #373365
+ if tc-is-cross-compiler ; then
+ export ac_cv_file__dev_urandom=yes
+ export ac_cv_struct_utsname=no
+ fi
+
+ econf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.a' -delete || die
+}