summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-04-21 13:41:40 -0400
committerMike Gilbert <floppym@gentoo.org>2023-04-21 13:41:40 -0400
commit7fba1ae8a6a18bd43afc1f23171b6cbfab7832aa (patch)
tree76e30d3cc851eee8ce6e5b0dcb757dde8e326dd1 /net-dialup
parentapp-text/lowdown: Get rid of artificial libbsd dep (bug #904729) (diff)
downloadgentoo-7fba1ae8a6a18bd43afc1f23171b6cbfab7832aa.tar.gz
gentoo-7fba1ae8a6a18bd43afc1f23171b6cbfab7832aa.tar.bz2
gentoo-7fba1ae8a6a18bd43afc1f23171b6cbfab7832aa.zip
net-dialup/ppp: fix pppol2tp plugin with USE=-ipv6
Closes: https://bugs.gentoo.org/904740 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/files/ppp-2.4.9-pppol2tp-ipv6.patch28
-rw-r--r--net-dialup/ppp/ppp-2.4.9-r9.ebuild (renamed from net-dialup/ppp/ppp-2.4.9-r8.ebuild)3
2 files changed, 30 insertions, 1 deletions
diff --git a/net-dialup/ppp/files/ppp-2.4.9-pppol2tp-ipv6.patch b/net-dialup/ppp/files/ppp-2.4.9-pppol2tp-ipv6.patch
new file mode 100644
index 000000000000..40773b2b0d54
--- /dev/null
+++ b/net-dialup/ppp/files/ppp-2.4.9-pppol2tp-ipv6.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/904740
+https://github.com/ppp-project/ppp/pull/319
+
+From 44a70d6f9eb6d1843868da1d45de382134a03630 Mon Sep 17 00:00:00 2001
+From: str8fast <52187302+str8fast@users.noreply.github.com>
+Date: Thu, 28 Oct 2021 14:55:56 +0000
+Subject: [PATCH] pppol2tp.c add '#ifdef INET6' for optional ipv6
+
+Without it, l2tp daemon can't launch ppp, cuz undefined symbol ipv6_up_notifier.
+---
+ pppd/plugins/pppol2tp/pppol2tp.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/pppd/plugins/pppol2tp/pppol2tp.c b/pppd/plugins/pppol2tp/pppol2tp.c
+index ed2d7c79..c9902afe 100644
+--- a/pppd/plugins/pppol2tp/pppol2tp.c
++++ b/pppd/plugins/pppol2tp/pppol2tp.c
+@@ -509,8 +509,10 @@ void plugin_init(void)
+ */
+ add_notifier(&ip_up_notifier, pppol2tp_ip_up, NULL);
+ add_notifier(&ip_down_notifier, pppol2tp_ip_down, NULL);
++#ifdef INET6
+ add_notifier(&ipv6_up_notifier, pppol2tp_ip_up, NULL);
+ add_notifier(&ipv6_down_notifier, pppol2tp_ip_down, NULL);
++#endif
+ }
+
+ struct channel pppol2tp_channel = {
diff --git a/net-dialup/ppp/ppp-2.4.9-r8.ebuild b/net-dialup/ppp/ppp-2.4.9-r9.ebuild
index bd9aed59ed9f..6e5887b815f6 100644
--- a/net-dialup/ppp/ppp-2.4.9-r8.ebuild
+++ b/net-dialup/ppp/ppp-2.4.9-r9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,6 +40,7 @@ src_prepare() {
eapply "${FILESDIR}"/${P}-fix-MPPE-sstpc.patch
eapply "${FILESDIR}"/${P}-fix-clang-nested-functions.patch
eapply "${FILESDIR}"/${P}-fix-openssl-sysroot-clang.patch
+ eapply "${FILESDIR}"/${P}-pppol2tp-ipv6.patch
#IPX Support is removed in kernel >= 5.15
sed -i 's/-DIPX_CHANGE //' pppd/Makefile.linux || die