summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-30 21:17:17 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-11-01 22:55:07 +0100
commitfbc27b52508507e3f5a88f40daa66974cbe16cbb (patch)
treee2e4825c4062cf59b28ebd71108f13c8cb2869db /net-dialup
parentnet-dns/fpdns: Port to EAPI 8 (diff)
downloadgentoo-fbc27b52508507e3f5a88f40daa66974cbe16cbb.tar.gz
gentoo-fbc27b52508507e3f5a88f40daa66974cbe16cbb.tar.bz2
gentoo-fbc27b52508507e3f5a88f40daa66974cbe16cbb.zip
net-dialup/linux-atm: Port to EAPI 8
Closes: https://bugs.gentoo.org/819357 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/22767 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/linux-atm/linux-atm-2.5.2-r1.ebuild (renamed from net-dialup/linux-atm/linux-atm-2.5.2.ebuild)23
1 files changed, 11 insertions, 12 deletions
diff --git a/net-dialup/linux-atm/linux-atm-2.5.2.ebuild b/net-dialup/linux-atm/linux-atm-2.5.2-r1.ebuild
index 4197658ac869..4c27be104939 100644
--- a/net-dialup/linux-atm/linux-atm-2.5.2.ebuild
+++ b/net-dialup/linux-atm/linux-atm-2.5.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch flag-o-matic libtool linux-info
+inherit autotools flag-o-matic linux-info
DESCRIPTION="Tools for ATM"
HOMEPAGE="http://linux-atm.sourceforge.net/"
@@ -12,31 +12,30 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="static-libs"
-RDEPEND=""
-DEPEND="virtual/yacc"
+BDEPEND="virtual/yacc"
RESTRICT="test"
-DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS )
-
CONFIG_CHECK="~ATM"
+PATCHES=(
+ "${FILESDIR}"/${P}-headers.patch
+ "${FILESDIR}"/${P}-linux-5.2-SIOCGSTAMP.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-headers.patch
- epatch "${FILESDIR}"/${P}-linux-5.2-SIOCGSTAMP.patch
+ default
sed -i '/#define _LINUX_NETDEVICE_H/d' \
src/arpd/*.c || die "sed command on arpd/*.c files failed"
- elibtoolize
+ eautoreconf
}
src_configure() {
append-flags -fno-strict-aliasing
-
- econf $(use_enable static-libs static)
+ econf
}
src_install() {