summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-04-28 12:18:17 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-04-28 12:19:02 -0400
commit24de16bd1d859a3eba6c4313b64f86c85934a702 (patch)
tree66a403aa483264dc8953492294df76760da9635d /net-dns/c-ares/c-ares-1.16.0.ebuild
parentdev-perl/Archive-Tar-Wrapper: Bump to version 0.370.0 (diff)
downloadgentoo-24de16bd1d859a3eba6c4313b64f86c85934a702.tar.gz
gentoo-24de16bd1d859a3eba6c4313b64f86c85934a702.tar.bz2
gentoo-24de16bd1d859a3eba6c4313b64f86c85934a702.zip
net-dns/c-ares: version bump to 1.16.0
Closes: https://bugs.gentoo.org/714800 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-dns/c-ares/c-ares-1.16.0.ebuild')
-rw-r--r--net-dns/c-ares/c-ares-1.16.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-dns/c-ares/c-ares-1.16.0.ebuild b/net-dns/c-ares/c-ares-1.16.0.ebuild
new file mode 100644
index 000000000000..b56e75cd76c6
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.16.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.haxx.se/"
+SRC_URI="https://${PN}.haxx.se/download/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE="static-libs"
+
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.12.0-remove-tests.patch
+ eapply_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}