summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-11 00:45:13 +0100
committerSam James <sam@gentoo.org>2021-08-11 00:45:18 +0100
commitc06fd172f1183f13dd6802abd5c3585987f4bc86 (patch)
treeae7bc80dc3c264c754938cbdfe8fed15e5f22562 /net-dns/c-ares/c-ares-1.17.2.ebuild
parentdev-python/cloudscraper: Add nodejs as a test dep., fix BDEPEND (diff)
downloadgentoo-c06fd172f1183f13dd6802abd5c3585987f4bc86.tar.gz
gentoo-c06fd172f1183f13dd6802abd5c3585987f4bc86.tar.bz2
gentoo-c06fd172f1183f13dd6802abd5c3585987f4bc86.zip
net-dns/c-ares: add 1.17.2
Now with tests. Bug: https://bugs.gentoo.org/807604 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns/c-ares/c-ares-1.17.2.ebuild')
-rw-r--r--net-dns/c-ares/c-ares-1.17.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-dns/c-ares/c-ares-1.17.2.ebuild b/net-dns/c-ares/c-ares-1.17.2.ebuild
new file mode 100644
index 000000000000..2a2ad767296f
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.17.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.haxx.se/"
+SRC_URI="https://${PN}.haxx.se/download/${P}.tar.gz"
+
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris"
+IUSE="static-libs test"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+multilib_src_configure() {
+ # Needed for running unit tests only
+ # Violates sandbox and tests pass fine without
+ ax_cv_uts_namespace=no \
+ ax_cv_user_namespace=no \
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}"/test || die
+
+ # We're skipping the "real" network tests with the filter
+ # see https://github.com/c-ares/c-ares/tree/main/test
+ ./arestest --gtest_filter=-*Live* || die "arestest failed!"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}