summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-24 15:52:28 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-24 15:52:28 +0200
commit6f85dde36d8637766806ca3c86033806ef5ea5e3 (patch)
treeb46a80c3a9d2d5edb33eb9a376bc1b67aac4c829 /net-dns/coredns/coredns-1.2.0.ebuild
parentwww-apps/hugo: Version bump to 0.45 (diff)
downloadgentoo-6f85dde36d8637766806ca3c86033806ef5ea5e3.tar.gz
gentoo-6f85dde36d8637766806ca3c86033806ef5ea5e3.tar.bz2
gentoo-6f85dde36d8637766806ca3c86033806ef5ea5e3.zip
net-dns/coredns: Version bump to 1.2.0
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-dns/coredns/coredns-1.2.0.ebuild')
-rw-r--r--net-dns/coredns/coredns-1.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-dns/coredns/coredns-1.2.0.ebuild b/net-dns/coredns/coredns-1.2.0.ebuild
new file mode 100644
index 000000000000..6f5e14c982cf
--- /dev/null
+++ b/net-dns/coredns/coredns-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_VENDOR=( "github.com/mholt/caddy b33b24fc9e9d50ce73ec386e44c316d70c47642c"
+ "github.com/miekg/dns 5a2b9fab83ff0f8bfc99684bd5f43a37abe560f1"
+ "github.com/prometheus/client_golang f504d69affe11ec1ccb2e5948127f86878c9fd57"
+ "github.com/beorn7/perks 3a771d992973f24aa725d07868b467d1ddfceafb"
+ "github.com/prometheus/procfs 780932d4fbbe0e69b84c34c20f5c8d0981e109ea"
+ "golang.org/x/net b68f30494add4df6bd8ef5e82803f308e7f7c59c github.com/golang/net"
+ "golang.org/x/text ece95c760240037f89ebcbdd7155ac8cb52e38fa github.com/golang/text"
+)
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-build golang-vcs-snapshot
+
+GITCOMMIT="231c2c0ef3fb921f5cae31ff4a2f7c6653da01ad"
+ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A DNS server that chains middleware"
+HOMEPAGE="https://github.com/coredns/coredns"
+
+SRC_URI="${ARCHIVE_URI}
+ ${EGO_VENDOR_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -v -ldflags="-X github.com/coredns/coredns/coremain.GitCommit=${GITCOMMIT}" || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN}
+ dobin ${PN}
+ dodoc README.md
+ popd || die
+}