summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <ya@sysdump.net>2018-04-26 21:36:44 -0700
committerPatrice Clement <monsieurp@gentoo.org>2018-04-30 18:08:43 +0200
commita5bd29d5fb7ce0fcce654b327222e4de4115eec9 (patch)
treea109da64e7a05af06d9e1ef61bd1c62060b8bd1a /net-dns/dnscrypt-proxy
parentmedia-sound/flacon: version bump to 4.1.0. (diff)
downloadgentoo-a5bd29d5fb7ce0fcce654b327222e4de4115eec9.tar.gz
gentoo-a5bd29d5fb7ce0fcce654b327222e4de4115eec9.tar.bz2
gentoo-a5bd29d5fb7ce0fcce654b327222e4de4115eec9.zip
net-dns/dnscrypt-proxy: version bump to 2.0.11.
Package-Manager: Portage-2.3.31, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8156
Diffstat (limited to 'net-dns/dnscrypt-proxy')
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.11.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index d412229c663d..2ec4f3124460 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,2 +1,3 @@
DIST dnscrypt-proxy-1.9.5.tar.bz2 1290573 BLAKE2B 8f16fdb58012e00a8b58d36364377c3bc25158b9484a8df2bd6bc98d1c9cbf5ac758997e31f95ecaeb9da2f6b7272316c5a4a1c069a39549fbc1c1b136857da0 SHA512 84c0f7587521b3a198292cf20dd71cb592ccf8a9e003abbc62c5ca112f6c5ed27c49b1642cf91f403d52b4147e25f24af540b65cecfcf93814338329097df836
DIST dnscrypt-proxy-2.0.10.tar.gz 2773118 BLAKE2B 331b62c84cf84f26757dd5e663d5ea8fa59b90a2b149cac5e795b6f7edad810b7dcd0fa2e6e9ce77d6d19d9d708a9ed7d30a7e8d43986545c6f38c3e623e3681 SHA512 b28bbce986bace9c4ee1acfe5b372b9f847d5a0a199b085ead31813ad697753b6a25cead72a90a1967bd473bb4bcb591a384765b2de9af817af0dde3d33dcb58
+DIST dnscrypt-proxy-2.0.11.tar.gz 2774458 BLAKE2B 36c9109a682a0d70c32910a44a64f49ebf0a958660154c10bf3687da3fdaa405e8add43717267f30a79d96941160cda5994704060a78e2ee6bbeddc55ff87766 SHA512 5e306c3bff65d0375b650666e2191c6f54e72bb0d2d2f6f8f7b941ffc063eb7eb244a52eb69b0b008dc566e9a6ce8a8f75929edb6762fad4751d966aa2da98a0
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.11.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.11.ebuild
new file mode 100644
index 000000000000..948f785d3d5f
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.11.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/jedisct1/${PN}"
+
+inherit fcaps golang-build systemd user
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="systemd"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+pkg_setup() {
+ enewgroup dnscrypt
+ enewuser dnscrypt -1 -1 /var/empty dnscrypt
+}
+
+src_prepare() {
+ default
+ # Create directory structure suitable for building
+ mkdir -p "src/${EGO_PN%/*}" || die
+ mv "${PN}" "src/${EGO_PN}" || die
+ mv "vendor" "src/" || die
+
+ if use systemd; then
+ sed -i 's|\['\''127\.0\.0\.1:53'\'', '\''\[::1\]:53'\''\]|\[\]|' \
+ "src/${EGO_PN}"/example-dnscrypt-proxy.toml || die
+ fi
+}
+
+src_install() {
+ dobin dnscrypt-proxy
+
+ insinto /etc/dnscrypt-proxy
+ newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+ doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
+ doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
+
+ insinto "/usr/share/dnscrypt-proxy"
+ doins -r "utils/generate-domains-blacklists/."
+
+ newinitd "${FILESDIR}"/dnscrypt-proxy.initd-r2 dnscrypt-proxy
+ newconfd "${FILESDIR}"/dnscrypt-proxy.confd-r2 dnscrypt-proxy
+ systemd_dounit systemd/dnscrypt-proxy.service
+ systemd_dounit systemd/dnscrypt-proxy.socket
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if ! use filecaps; then
+ ewarn "'filecaps' USE flag is disabled"
+ ewarn "${PN} will fail to listen on port 53 if started via OpenRC"
+ ewarn "please either change port to > 1024, configure to run ${PN} as root"
+ ewarn "or re-enable 'filecaps'"
+ ewarn
+ fi
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ ${v} == 1.* ]] ; then
+ elog "Version 2.x.x is a complete rewrite of ${PN}"
+ elog "please clean up old config/log files"
+ elog
+ fi
+ done
+
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "Starting with version 2.0.9 ${PN} unit changed:"
+ elog "It now runs as an unprivileged user with dynamic UID/GID"
+ elog "and privately stores log and cache files"
+ elog
+ elog "See man:systemd.exec, man:nss-systemd"
+ elog
+ elog "Edit ${PN}.socket if you need to change port and address"
+ elog
+
+ fi
+
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver 127.0.0.1"
+ elog
+ elog "Also see https://github.com/jedisct1/${PN}/wiki"
+}