summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2018-07-23 10:49:53 -0700
committerPatrick McLean <chutzpah@gentoo.org>2018-07-23 10:49:53 -0700
commit8cafd8008ac941241b6897de75a4fefd3df74184 (patch)
tree96da12ad69b05f4dfb3a9c3fc35d23cfb9af41b3 /net-dns/dnsmasq
parentapp-xemacs/ebuild-mode: Remove old. (diff)
downloadgentoo-8cafd8008ac941241b6897de75a4fefd3df74184.tar.gz
gentoo-8cafd8008ac941241b6897de75a4fefd3df74184.tar.bz2
gentoo-8cafd8008ac941241b6897de75a4fefd3df74184.zip
net-dns/dnsmasq: Remove 2.78 (security bug #645704)
Closes: https://bugs.gentoo.org/645704 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/Manifest1
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.78.ebuild195
2 files changed, 0 insertions, 196 deletions
diff --git a/net-dns/dnsmasq/Manifest b/net-dns/dnsmasq/Manifest
index 1a7044b3e9e9..f33cc77e8a81 100644
--- a/net-dns/dnsmasq/Manifest
+++ b/net-dns/dnsmasq/Manifest
@@ -1,2 +1 @@
-DIST dnsmasq-2.78.tar.xz 489172 BLAKE2B 996b59181c4b582b74c91be073e62f0756d2e4c67ee36ff825b6973699f60e44959bb0451bbb8623f277e5a8378cda987a300eee6ec9398ae99284b302da2747 SHA512 9b79b84e5a768d52f90f6335ccef2c404ecd7a13e78e49f4cd0755fffc6cf34d0dc96ad4c72cad1dab3c5743a8d0d789b3e9b6e625b03c5675bb898ca61a698b
DIST dnsmasq-2.79.tar.xz 493036 BLAKE2B 91152c52aef06def74151f6fbae9153d25261ba5e6a728cbab503c074967963e40dce39d93a0fbe4c5497c9313ac24d495cc8233934c00d4ab82aefe83b01ccd SHA512 2c06212696ab55e1584f6133872f5b196013509e4b1822d0457787b456e14341afdde887749e370a2e512124cb4138f012f4601b08690707be4acc7cf2f2876f
diff --git a/net-dns/dnsmasq/dnsmasq-2.78.ebuild b/net-dns/dnsmasq/dnsmasq-2.78.ebuild
deleted file mode 100644
index 8ffbd1829a6f..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.78.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic user systemd
-
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
-
-IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec +id idn libidn2 +inotify"
-IUSE+=" ipv6 lua nls script selinux static tftp"
-
-DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-
-CDEPEND="dbus? ( sys-apps/dbus )
- idn? (
- !libidn2? ( net-dns/libidn )
- libidn2? ( >=net-dns/libidn2-2.0 )
- )
- lua? ( dev-lang/lua:* )
- conntrack? ( net-libs/libnetfilter_conntrack )
- nls? ( sys-devel/gettext )
-"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- dnssec? (
- dev-libs/nettle[gmp]
- static? ( dev-libs/nettle[static-libs(+)] )
- )
- virtual/pkgconfig
-"
-
-RDEPEND="${CDEPEND}
- dnssec? (
- !static? (
- dev-libs/nettle[gmp]
- )
- )
- selinux? ( sec-policy/selinux-dnsmasq )
-"
-
-REQUIRED_USE="dhcp-tools? ( dhcp )
- lua? ( script )
- libidn2? ( idn )"
-
-use_have() {
- local useflag no_only uword
- if [[ $1 == '-n' ]]; then
- no_only=1
- shift
- fi
- useflag="${1}"
- shift
-
- uword="${1:-${useflag}}"
- shift
-
- while [[ ${uword} ]]; do
- uword="${uword^^}"
-
- if ! use "${useflag}"; then
- echo -n " -DNO_${uword}"
- elif [[ -z "${no_only}" ]]; then
- echo -n " -DHAVE_${uword}"
- fi
- uword="${1}"
- shift
- done
-}
-
-pkg_pretend() {
- if use static; then
- einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
- use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense; the static USE flag is ignored."
- fi
-}
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- default
-
- sed -i -r 's:lua5.[0-9]+:lua:' Makefile
- sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
-}
-
-src_configure() {
- COPTS="$(use_have -n auth-dns auth)"
- COPTS+="$(use_have conntrack)"
- COPTS+="$(use_have dbus)"
- COPTS+="$(use libidn2 || use_have idn)"
- COPTS+="$(use_have libidn2)"
- COPTS+="$(use_have -n inotify)"
- COPTS+="$(use_have -n dhcp dhcp dhcp6)"
- COPTS+="$(use_have -n ipv6 ipv6 dhcp6)"
- COPTS+="$(use_have -n id id)"
- COPTS+="$(use_have lua luascript)"
- COPTS+="$(use_have -n script)"
- COPTS+="$(use_have -n tftp)"
- COPTS+="$(use_have dnssec)"
- COPTS+="$(use_have static dnssec_static)"
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- COPTS="${COPTS}" \
- CONFFILE="/etc/${PN}.conf" \
- all$(use nls && echo "-i18n")
-
- use dhcp-tools && emake -C contrib/lease-tools \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- all
-}
-
-src_install() {
- local lingua puid
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- COPTS="${COPTS}" \
- DESTDIR="${D}" \
- install$(use nls && echo "-i18n")
-
- for lingua in "${DM_LINGUAS[@]}"; do
- has ${lingua} ${LINGUAS-${lingua}} \
- || rm -rf "${D}"/usr/share/locale/${lingua}
- done
- [[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
-
- dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
- dodoc -r logo
-
- docinto html/
- dodoc *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r3 ${PN}
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
-
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- insinto /usr/share/dnsmasq
- doins trust-anchors.conf
-
- if use dhcp; then
- dodir /var/lib/misc
- newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r2 ${PN}
- fi
- if use dbus; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-
- if use dhcp-tools; then
- dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
- doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
- if use ipv6; then
- dosbin contrib/lease-tools/dhcp_release6
- doman contrib/lease-tools/dhcp_release6.1
- fi
- fi
-
- systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-}
-
-pkg_preinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f /var/lib/misc/dnsmasq.leases ]] && cp /var/lib/misc/dnsmasq.leases "${T}"
-}
-
-pkg_postinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f "${T}"/dnsmasq.leases ]] && cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
-}