summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-04-15 16:37:17 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-04-15 16:37:17 -0700
commitee7be1b8c8d143b052c2d0c00974e039430cdc37 (patch)
tree5120abe69d85df0454cddc76f05a9257d342eb82 /net-dns/dnsmasq
parentnet-misc/curl: version bump to 7.67.1 (diff)
downloadgentoo-ee7be1b8c8d143b052c2d0c00974e039430cdc37.tar.gz
gentoo-ee7be1b8c8d143b052c2d0c00974e039430cdc37.tar.bz2
gentoo-ee7be1b8c8d143b052c2d0c00974e039430cdc37.zip
net-dns/dnsmasq-2.85: Version bump (bug #782130)
Bug: https://bugs.gentoo.org/782130 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/Manifest1
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.85.ebuild217
2 files changed, 218 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/Manifest b/net-dns/dnsmasq/Manifest
index 8d32f2d0f7fa..f65dc2f4d6e3 100644
--- a/net-dns/dnsmasq/Manifest
+++ b/net-dns/dnsmasq/Manifest
@@ -1,2 +1,3 @@
DIST dnsmasq-2.83.tar.xz 513880 BLAKE2B 16220fd7eac03f3ba70b014ace3c9775a85b31cdbabd7680d88a87697453a54bfec4c553207477f416032e679dbdaf3ca6c8bb56b72ee423540e0bedf0621865 SHA512 1eaade775dc19658afe825407c10456ab954b82034644bb19af2594d737ceae17ff2cee7f1f917e8e8b2dadbfbcb83dd8b842c0693fcac71487a5fade1eb4b05
DIST dnsmasq-2.84.tar.xz 514216 BLAKE2B 2bca97c16bcf32e0126eb50dc14b82a1f37e1635ebd1dc205e9a92455640fcbb98c093be725768ba9ced84443e451775f8556a164c82967e09e1df4bf7fc901b SHA512 e84bdcdf3cf35f08e8492eb5aa89ee6543233bdb821d01f164783bd6d0913ec01c513e85e2109352c77e77142a1a94bedcd3361f37d7b2a9a5d35a02448e85c6
+DIST dnsmasq-2.85.tar.xz 518316 BLAKE2B b7c081132c65d67b65f797bdbc603930c1509717bc1b5209b12f72fa3f01b4bae2f26a5387f95ef20317cd3d60e097c0b8bef5e019a35013f3ed2acce9fe9e89 SHA512 8beefe76b46f7d561f40d0900ba68b260a199cb62ab5b653746e3a1104c04fb8899b9e7a160a1be4fe8782bfb1607b556e9ffb9c25c4e99653e4bc74fcc03b09
diff --git a/net-dns/dnsmasq/dnsmasq-2.85.ebuild b/net-dns/dnsmasq/dnsmasq-2.85.ebuild
new file mode 100644
index 000000000000..018e108669b5
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.85.ebuild
@@ -0,0 +1,217 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit toolchain-funcs flag-o-matic lua-single systemd
+
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec +dumpfile id idn libidn2"
+IUSE+=" +inotify ipv6 lua nettlehash nls script selinux static tftp"
+
+DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
+
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+COMMON_DEPEND="
+ acct-group/dnsmasq
+ acct-user/dnsmasq
+ dbus? ( sys-apps/dbus:= )
+ idn? (
+ !libidn2? ( net-dns/libidn:0= )
+ libidn2? ( >=net-dns/libidn2-2.0:= )
+ )
+ lua? ( ${LUA_DEPS} )
+ conntrack? ( net-libs/libnetfilter_conntrack:= )
+ nls? ( sys-devel/gettext )
+"
+
+DEPEND="${COMMON_DEPEND}
+ dnssec? (
+ dev-libs/nettle:=[gmp]
+ static? ( >=dev-libs/nettle-3.4[static-libs(+)] )
+ )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ dnssec? (
+ !static? ( >=dev-libs/nettle-3.4:=[gmp] )
+ )
+ selinux? ( sec-policy/selinux-dnsmasq )
+"
+
+REQUIRED_USE="
+ dhcp-tools? ( dhcp )
+ dnssec? ( !nettlehash )
+ lua? (
+ script
+ ${LUA_REQUIRED_USE}
+ )
+ libidn2? ( idn )
+"
+
+use_have() {
+ local no_only
+ if [[ ${1} == '-n' ]]; then
+ no_only=1
+ shift
+ fi
+ local useflag="${1}"
+ shift
+
+ local uword="${1:-${useflag}}"
+ shift
+
+ while [[ ${uword} ]]; do
+ uword="${uword^^}"
+
+ if ! use "${useflag}"; then
+ printf -- " -DNO_%s" "${uword}"
+ elif [[ -z "${no_only}" ]]; then
+ printf -- " -DHAVE_%s" "${uword}"
+ fi
+ uword="${1}"
+ shift
+ done
+}
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+pkg_pretend() {
+ if use static; then
+ einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
+ use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense;" \
+ "in this case the static USE flag does nothing."
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i -r 's:lua5.[0-9]+:lua:' Makefile || die
+ sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" \
+ dnsmasq.conf.example || die
+}
+
+src_configure() {
+ COPTS=(
+ $(use_have -n auth-dns auth)
+ $(use_have conntrack)
+ $(use_have dbus)
+ $(use libidn2 || use_have idn)
+ $(use_have libidn2)
+ $(use_have -n inotify)
+ $(use_have -n dhcp dhcp dhcp6)
+ $(use_have -n ipv6 ipv6 dhcp6)
+ $(use_have -n id id)
+ $(use_have lua luascript)
+ $(use_have -n script)
+ $(use_have -n tftp)
+ $(use_have dnssec)
+ $(use_have nettlehash)
+ $(use_have static dnssec_static)
+ $(use_have -n dumpfile)
+ )
+}
+
+src_compile() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ COPTS="${COPTS[*]}" \
+ CONFFILE="/etc/${PN}.conf" \
+ all$(use nls && printf -- "-i18n\n")
+
+ use dhcp-tools && emake -C contrib/lease-tools \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ all
+}
+
+src_install() {
+ local lingua puid
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ COPTS="${COPTS[*]}" \
+ DESTDIR="${ED}" \
+ install$(use nls && printf -- "-i18n\n")
+
+ for lingua in "${DM_LINGUAS[@]}"; do
+ has ${lingua} ${LINGUAS-${lingua}} \
+ || rm -rf "${ED}"/usr/share/locale/${lingua}
+ done
+ [[ -d "${D}"/usr/share/locale/ ]] && \
+ rmdir --ignore-fail-on-non-empty "${ED}"/usr/share/locale/
+
+ dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
+ dodoc -r logo
+
+ docinto html/
+ dodoc *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init-r4 ${PN}
+ newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/dnsmasq.logrotate ${PN}
+
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ insinto /usr/share/dnsmasq
+ doins trust-anchors.conf
+
+ if use dhcp; then
+ keepdir /var/lib/misc
+ newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r3 ${PN}
+ fi
+ if use dbus; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+
+ if use dhcp-tools; then
+ dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
+ doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
+ if use ipv6; then
+ dosbin contrib/lease-tools/dhcp_release6
+ doman contrib/lease-tools/dhcp_release6.1
+ fi
+ fi
+
+ systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
+}
+
+pkg_preinst() {
+ [[ -f /var/lib/misc/dnsmasq.leases ]] && \
+ cp /var/lib/misc/dnsmasq.leases "${T}"
+}
+
+pkg_postinst() {
+ [[ -f "${T}"/dnsmasq.leases ]] && \
+ cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
+}