summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-22 14:19:49 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-22 15:41:31 +0200
commit4b99c0e37947f6be1cdb6ff897477e590a0480a9 (patch)
treee4e210ff6747ef5937ae1b4e28f82ae96e563320 /net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild
parentnet-dns/dnsviz: python3_{7,8} port (diff)
downloadgentoo-4b99c0e37947f6be1cdb6ff897477e590a0480a9.tar.gz
gentoo-4b99c0e37947f6be1cdb6ff897477e590a0480a9.tar.bz2
gentoo-4b99c0e37947f6be1cdb6ff897477e590a0480a9.zip
net-dns/dnsviz: replace libnacl with py-cryptography
This will also add Ed448 support. Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild')
-rw-r--r--net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild b/net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..cffca2ff2de9
--- /dev/null
+++ b/net-dns/dnsviz/dnsviz-0.8.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1 eutils
+
+DESCRIPTION="Tool suite for analysis and visualization of DNS and DNSSEC"
+HOMEPAGE="https://dnsviz.net/"
+SRC_URI="https://github.com/dnsviz/dnsviz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ >=dev-python/m2crypto-0.31.0[${PYTHON_USEDEP}]
+ >=dev-python/pygraphviz-1.3.1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ ${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.8.2-add-ed448-support.patch )
+
+python_prepare_all() {
+ # Fix the ebuild to use correct FHS/Gentoo policy paths for 0.8.2
+ sed -i "s*share/doc/dnsviz*share/doc/dnsviz-${PV}*g" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Support for extra feature can be get from:"
+ optfeature "Support for pre-deployment testing" net-dns/bind
+
+ # Warn about extra requirements for >=OpenSSL 1.1.0
+ if has_version '=dev-libs/openssl-1.1*'; then
+ echo
+ ewarn "With OpenSSL version 1.1.0 and later,the OpenSSL GOST Engine"
+ ewarn "is necessary to validate DNSSEC signatures with algorithm 12"
+ ewarn "(GOST R 34.10-2001) and digests of type 3 (GOST R 34.11-94)"
+ ewarn "OpenSSL GOST Engine can be get from --> dev-libs/gost-engine"
+ fi
+}