summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2021-11-23 08:35:38 +0100
committerFlorian Schmaus <flow@gentoo.org>2021-11-23 10:40:19 +0100
commita1ce290f619f32d7cf13552eaca6063cf6f16c54 (patch)
treedf5358dd1d69dbedfa04f464c237a159f2c9a05e /net-dns/knot
parentapp-misc/tdfsb: update EAPI 5 -> 8 (diff)
downloadgentoo-a1ce290f619f32d7cf13552eaca6063cf6f16c54.tar.gz
gentoo-a1ce290f619f32d7cf13552eaca6063cf6f16c54.tar.bz2
gentoo-a1ce290f619f32d7cf13552eaca6063cf6f16c54.zip
net-dns/knot: bump to 3.1.4
Closes: https://bugs.gentoo.org/826366 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-dns/knot')
-rw-r--r--net-dns/knot/Manifest1
-rw-r--r--net-dns/knot/knot-3.1.4.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index 6c122ea04df1..458390affa2e 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,3 +1,4 @@
DIST knot-3.1.1.tar.xz 1402352 BLAKE2B d6f9d29de153b5bdea8a294ae3d65131a0bdcc339ecdc507a9e1429a9cc50752e91f14ea84a7446de76869c6f129d571e9b6b4f9b048618941c4f4c0d667dbff SHA512 44c2973025e752f73ebd6bc78dad5c48c1c1432b62ec3b6d75b5876af4dd21aeed94f78523ef85cd6a986ff27789143a0a67450819c0b75ffa627d06b98e1b0b
DIST knot-3.1.2.tar.xz 1406684 BLAKE2B a849bf651357e462c5a0afb16e42bcd85bb310980c83b4c642bcf99ddfd17a59e5f5fd5f9fd58b21bcac2e287c57351b3b09cf3f4054ef51243b5226bf0bcc88 SHA512 e72f249f6291980cc69f90dca54cd8ba3ffbc617a1e69e441a48bdcbf46afb9fc202bbb1f88a93887fd264ddb59ad42ff6765c9bd0c1fa4789f035a902a3907a
DIST knot-3.1.3.tar.xz 1407576 BLAKE2B 03cde89e32ac2440e721157db1af9b9cbb40ad2d8d813b0d8bc26fe1feb28f59055a3cbe287d50adb13f5190ce3ed532521189997d03b4fe9e4264f309032e23 SHA512 537013e914c3f00615a384c92da06c40bb33871e7dbd28e987280d62d91df42026774cfe0596ac72a218dafa650d8d600b1d831dd0a5c28a9fd796c5cd799838
+DIST knot-3.1.4.tar.xz 1408656 BLAKE2B 637371e5cc9aa0b880fda96d1d61f9e168cc96c244551b17381a1641a8b6ace7cac7ac6b7cf40fb2e86ac8f606be8d1342e548e5cadd64770610b2a5aa35f1f0 SHA512 307667a12b989fee443832d4642fc927231f38f0331439c8c7196c489d196245eca368d96a36fe49639b773f652f7cb80bf0c16bc1ad107e11b47b70e1f04060
diff --git a/net-dns/knot/knot-3.1.4.ebuild b/net-dns/knot/knot-3.1.4.ebuild
new file mode 100644
index 000000000000..4b7058faa52a
--- /dev/null
+++ b/net-dns/knot/knot-3.1.4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic systemd
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+KNOT_MODULES=(
+ "+cookies"
+ "+dnsproxy"
+ "dnstap"
+ "geoip"
+ "+noudp"
+ "+onlinesign"
+ "+queryacl"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ acct-group/knot
+ acct-user/knot
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu:=
+ dev-python/lmdb
+ net-libs/gnutls:=
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c:=
+ )
+ geoip? ( dev-libs/libmaxminddb:= )
+ idn? (
+ !libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
+ libidn2? ( net-dns/libidn2:= )
+ )
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ if use riscv; then
+ append-libs -latomic
+ fi
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+
+ default
+
+ rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}