summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-11-02 18:37:19 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-11-02 18:37:39 -0400
commita27c145c86c403483c9c0289e43daab8fe148e50 (patch)
tree0d49ebaf9924c12a7aea62e29ce2e91235a14d38 /net-dns/libidn2
parentkde-misc/plasma-applet-weather-widget: New package (diff)
downloadgentoo-a27c145c86c403483c9c0289e43daab8fe148e50.tar.gz
gentoo-a27c145c86c403483c9c0289e43daab8fe148e50.tar.bz2
gentoo-a27c145c86c403483c9c0289e43daab8fe148e50.zip
net-dns/libidn2: support multilib for curl, see bug #597760c2
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-dns/libidn2')
-rw-r--r--net-dns/libidn2/libidn2-0.10-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-dns/libidn2/libidn2-0.10-r1.ebuild b/net-dns/libidn2/libidn2-0.10-r1.ebuild
new file mode 100644
index 000000000000..6290b07978da
--- /dev/null
+++ b/net-dns/libidn2/libidn2-0.10-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2"
+SRC_URI="mirror://gnu-alpha/libidn/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-examples.patch
+ "${FILESDIR}"/${P}-Werror.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}