summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-08-23 04:13:37 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-09-16 11:04:11 +0300
commit5b6cf56c35f53484063dfa46f0fa41df9432433d (patch)
tree52ec63e295e932ccfdf126f435ac0617bd9732ba /net-dns/mdns-repeater
parentdev-libs/stp: declare boost as dependency (diff)
downloadgentoo-5b6cf56c35f53484063dfa46f0fa41df9432433d.tar.gz
gentoo-5b6cf56c35f53484063dfa46f0fa41df9432433d.tar.bz2
gentoo-5b6cf56c35f53484063dfa46f0fa41df9432433d.zip
net-dns/mdns-repeater: update version
Migrate from bitbucket to github, respect system CFLAGS and LDFLAGS. Closes: https://bugs.gentoo.org/724962 Closes: https://bugs.gentoo.org/724944 Bug: https://bugs.gentoo.org/737896 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-dns/mdns-repeater')
-rw-r--r--net-dns/mdns-repeater/Manifest1
-rw-r--r--net-dns/mdns-repeater/files/mdns-repeater-1.11-system-compiler-options.patch33
-rw-r--r--net-dns/mdns-repeater/mdns-repeater-1.11.ebuild27
-rw-r--r--net-dns/mdns-repeater/metadata.xml2
4 files changed, 62 insertions, 1 deletions
diff --git a/net-dns/mdns-repeater/Manifest b/net-dns/mdns-repeater/Manifest
index 0615607d73d9..4dae469e6dc6 100644
--- a/net-dns/mdns-repeater/Manifest
+++ b/net-dns/mdns-repeater/Manifest
@@ -1 +1,2 @@
+DIST mdns-repeater-1.11.tar.gz 11220 BLAKE2B 88e6b68635be152c2fcd7eb0e5be038d694bae590edde283dec83b896c2380d83cc84d5e4cfb02b6ae957d75dd7525975e31c418d05f5732b5f41382fb130c31 SHA512 3f2fc83448db7ed84512ddc42d1769d1d7fa52aa92a4205d9956685fd5fd8b5c050b8a2c44d4b834e242568671fa278ac912f0b35f3c7cf41aa0ae8f1cf2a310
DIST mdns-repeater-28ecc2ab9a0e.tar.gz 10697 BLAKE2B 4272f20d08db060c27a0f1e6cd9cea6896b8f119e8b751cc25f64ecb4a542adaf55b31d8a380058371bcf7e26c4e13fd34dec8a11a58f37e270af9be6b04fc3b SHA512 06b8365a389ccc77bc31ebcbf7089e59bd2e03e4996e719f369e7c54dbc96b1ea57c9e0b82d4376fcb165160e04a48a3a679f9ab431344f46d74a3602e58a0d8
diff --git a/net-dns/mdns-repeater/files/mdns-repeater-1.11-system-compiler-options.patch b/net-dns/mdns-repeater/files/mdns-repeater-1.11-system-compiler-options.patch
new file mode 100644
index 000000000000..35eaa3675283
--- /dev/null
+++ b/net-dns/mdns-repeater/files/mdns-repeater-1.11-system-compiler-options.patch
@@ -0,0 +1,33 @@
+From 4d4f022eef0d0d14936288a5f6374c7a4b85c77c Mon Sep 17 00:00:00 2001
+From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
+Date: Sun, 23 Aug 2020 04:06:15 +0300
+Subject: [PATCH] Respect system CFLAGS and LDFLAGS
+
+---
+ Makefile | 10 +---------
+ 1 file changed, 1 insertion(+), 9 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index a04f707..ae4fe32 100644
+--- a/Makefile
++++ b/Makefile
+@@ -9,15 +9,7 @@ ZIP_FILES = mdns-repeater \
+
+ HGVERSION=$(shell hg parents --template "{latesttag}.{latesttagdistance}")
+
+-CFLAGS=-Wall
+-
+-ifdef DEBUG
+-CFLAGS+= -g
+-else
+-CFLAGS+= -Os
+-LDFLAGS+= -s
+-endif
+-
++CFLAGS+=-Wall
+ CFLAGS+= -DHGVERSION="\"${HGVERSION}\""
+
+ .PHONY: all clean
+--
+2.26.2
+
diff --git a/net-dns/mdns-repeater/mdns-repeater-1.11.ebuild b/net-dns/mdns-repeater/mdns-repeater-1.11.ebuild
new file mode 100644
index 000000000000..70e66393f0c6
--- /dev/null
+++ b/net-dns/mdns-repeater/mdns-repeater-1.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Multicast DNS repeater"
+HOMEPAGE="https://github.com/kennylevinsen/mdns-repeater"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+SRC_URI="https://github.com/kennylevinsen/mdns-repeater/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+PATCHES=(
+ "${FILESDIR}/${P}-system-compiler-options.patch"
+)
+
+src_compile() {
+ emake HGVERSION="${PV}" CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc README.txt
+}
diff --git a/net-dns/mdns-repeater/metadata.xml b/net-dns/mdns-repeater/metadata.xml
index 1306680b2568..4a16a9ff3c07 100644
--- a/net-dns/mdns-repeater/metadata.xml
+++ b/net-dns/mdns-repeater/metadata.xml
@@ -10,6 +10,6 @@
<name>Gentoo Proxy Maintainers Project</name>
</maintainer>
<upstream>
- <remote-id type="bitbucket">geekman/mdns-repeater</remote-id>
+ <remote-id type="github">kennylevinsen/mdns-repeater</remote-id>
</upstream>
</pkgmetadata>