summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-05 15:31:25 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-05 15:32:44 -0500
commit9d5eb87d92006e1d63a8e72da5996e59e1eb5ee8 (patch)
tree5b10641eab062f423aece827b4e9b7b3dd14093a /net-dns/mydns/mydns-1.2.8.31-r2.ebuild
parentdev-libs/libhome: Revbump for dependency change (diff)
downloadgentoo-9d5eb87d92006e1d63a8e72da5996e59e1eb5ee8.tar.gz
gentoo-9d5eb87d92006e1d63a8e72da5996e59e1eb5ee8.tar.bz2
gentoo-9d5eb87d92006e1d63a8e72da5996e59e1eb5ee8.zip
net-dns/mydns: Revbump for dependencies
Bug: https://bugs.gentoo.org/665966 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'net-dns/mydns/mydns-1.2.8.31-r2.ebuild')
-rw-r--r--net-dns/mydns/mydns-1.2.8.31-r2.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/net-dns/mydns/mydns-1.2.8.31-r2.ebuild b/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
new file mode 100644
index 000000000000..5f6aeb01f0cb
--- /dev/null
+++ b/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A DNS-Server which gets its data from a MySQL-/PostgreSQL-database"
+HOMEPAGE="http://www.mydns.pl/"
+SRC_URI="mirror://sourceforge/mydns-ng/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="alias debug nls mysql postgres ssl static status"
+
+RDEPEND="mysql? ( dev-db/mysql-connector-c:= )
+ nls? ( virtual/libintl )
+ postgres? ( dev-db/postgresql )
+ ssl? ( dev-libs/openssl:0= )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.12 )
+ sys-devel/bison"
+
+REQUIRED_USE="^^ ( mysql postgres )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.8.27-m4.patch"
+ "${FILESDIR}/${P}-texinfo.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alias) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_enable static) \
+ $(use_enable static static-build) \
+ $(use_enable status) \
+ $(use_with ssl openssl) \
+ --without-included-gettext
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS BUGS ChangeLog QUICKSTART* NEWS README* TODO
+ docinto contrib
+ dodoc contrib/*.php contrib/*.pl contrib/*.pm contrib/README*
+
+ newinitd "${FILESDIR}/mydns.initd" mydns
+ newconfd "${FILESDIR}/mydns.confd" mydns
+
+ ## Avoid file collision
+ rm -f "${ED}/usr/share/locale/locale.alias"
+
+ # Install config file
+ insinto /etc
+ newins mydns.conf mydns.conf
+ fowners root:root /etc/mydns.conf
+ fperms 0600 /etc/mydns.conf
+}
+
+pkg_postinst() {
+ if use postgres; then
+ elog "# createdb mydns"
+ elog "# /usr/sbin/mydns --create-tables | psql mydns"
+ elog
+ elog "to create the tables in the PostgreSQL-Database."
+ elog "For more info see QUICKSTART.postgres."
+ fi
+ if use mysql; then
+ elog "# mysqladmin -u <useruname> -p create mydns"
+ elog "# /usr/sbin/mydns --create-tables | mysql -u <username> -p mydns"
+ elog
+ elog "to create the tables in the MySQL-Database."
+ elog "For more info see QUICKSTART.mysql."
+ fi
+ elog
+}