summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2021-10-08 18:47:25 +0200
committerSven Wegener <swegener@gentoo.org>2021-10-08 21:09:56 +0200
commitcf8cb0aeecc74576640b486f44509cc86a5aca18 (patch)
tree51af9bb734ccb52451dd07dda8ca7e6ddf7cc488 /net-dns/pdns-recursor
parentnet-mail/cyrus-imapd: x86 stable wrt bug #816903 (diff)
downloadgentoo-cf8cb0aeecc74576640b486f44509cc86a5aca18.tar.gz
gentoo-cf8cb0aeecc74576640b486f44509cc86a5aca18.tar.bz2
gentoo-cf8cb0aeecc74576640b486f44509cc86a5aca18.zip
net-dns/pdns-recursor: Version bump to 4.4.6
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.4.6.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 3a7d33342f35..f0aa297eb727 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,2 +1,3 @@
DIST pdns-recursor-4.4.5.tar.bz2 1400394 BLAKE2B a373d15987860bd6b890e5aa5900f28623ff763a711e527b05c3de950c7fbec186dc5e085100008a8ee89bab24140b0f993357349ec04d968e7f386156cdefbc SHA512 21f4172bb8908cfb53e8d457533a85940b13da6733c2da3972b587e64a0f6d52bfd52b85d5d65769c33dd479ce89b6306bdd105c120ab99b32963e7f0cfbc2e2
+DIST pdns-recursor-4.4.6.tar.bz2 1403882 BLAKE2B 2f860128849cce29131300cbda2f2646c7fbaeeb704a6131933d3bbe205bdf1dddd45f9f79f74345b2dea34e56d145b9ef878c0cd6280ceeb075c196afe53d5e SHA512 0ac897da628fb133bd7cd3932e0a1d362c88c55cb07dc2d5d645f731dc8dbf5d18993967654a60156cba7eaac7869ee10a67987a2a492c0c239de9788188caf4
DIST pdns-recursor-4.5.5.tar.bz2 1472089 BLAKE2B 408bd0d11b0945de15fe22b290b127a9b7f9f053359a0269fb9e478ae536ed5c4b5ad3b5fa8b15d7786fdd0cdd8721d5a5cb66d46f816105e37ecd9fc9557854 SHA512 7df2e89eea55e870724370753b39d867e2b32fc8bcbdb3efaefa824917b16b9d382817dce7d551dc16d8ad0b0c04b3021cba310b47de969fe54c395eafe7706b
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.4.6.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.4.6.ebuild
new file mode 100644
index 000000000000..dc546d8cd6ca
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.4.6.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap protobuf snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ dnstap? ( protobuf )"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}