summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 20:34:34 +0100
committerSam James <sam@gentoo.org>2022-10-28 20:50:04 +0100
commit1b5460d5f945b8f7e9079dbbc4423bdcf5a5651b (patch)
treef516446fed10a494db3f259541c5d1aaf133d4ac /net-dns
parentnet-analyzer/wireshark: drop 4.0.0-r2 (diff)
downloadgentoo-1b5460d5f945b8f7e9079dbbc4423bdcf5a5651b.tar.gz
gentoo-1b5460d5f945b8f7e9079dbbc4423bdcf5a5651b.tar.bz2
gentoo-1b5460d5f945b8f7e9079dbbc4423bdcf5a5651b.zip
net-dns/dnscrypt-proxy: drop 2.1.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.1.ebuild105
-rw-r--r--net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.1.0-config-full-paths.patch76
3 files changed, 0 insertions, 182 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index 076d965057a9..a56cbe5c3d84 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,2 +1 @@
-DIST dnscrypt-proxy-2.1.1.tar.gz 6114345 BLAKE2B 9d68d94d1fc142d53ed74840080feca56d7abf606b8df9b2ebea7a69b75f13cdc93be53418e6101d30d31d6f4130b3794c1029a5972e129a4c06feeff7dd81e7 SHA512 1118d79aad8d3e3629616c203194a5346f00fcfe88783ebddc6f167d22a82006f26022e728c57905aa82997b87b77f0841f7c1b60e0f8e5335f9df142b759c21
DIST dnscrypt-proxy-2.1.2.tar.gz 6792121 BLAKE2B f6e69e9b7bba5bcaf49f710c78fc1b9607a8e791ad222da7af2a129de4807ecf87ddb7289aa79132a0d5ada588d2557beff618a79a341d168674bda7c8ba58ee SHA512 1b3598d60abc70141127aaaab5bf8bfaa76239d33e4220664dadd47f09544553e06eba6d82e5daf2c44c6da9c3c21c53683c2ff33db63257b782ad48c534bd54
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.1.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.1.ebuild
deleted file mode 100644
index 2f8f698a764a..000000000000
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/DNSCrypt/${PN}"
-
-inherit fcaps go-module systemd
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://${EGO_PN}.git"
-else
- SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc64 x86"
-fi
-
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/DNSCrypt/dnscrypt-proxy"
-
-LICENSE="Apache-2.0 BSD ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="+pie"
-
-BDEPEND=">=dev-lang/go-1.13"
-RDEPEND="
- acct-group/dnscrypt-proxy
- acct-user/dnscrypt-proxy
-"
-
-FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.1.0-config-full-paths.patch"
-)
-
-src_compile() {
- pushd "${PN}" >/dev/null || die
- go build -v -x -mod=readonly -mod=vendor -buildmode="$(usex pie pie default)" || die
- popd >/dev/null || die
-}
-
-src_test() {
- cd "${PN}" || die
- go test -mod=vendor -buildmode="$(usex pie pie default)" || die "Failed to run tests"
-}
-
-src_install() {
- pushd "${PN}" >/dev/null || die
-
- dobin dnscrypt-proxy
-
- insinto /etc/dnscrypt-proxy
- newins example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins example-{allowed,blocked}-{ips.txt,names.txt}
- doins example-{cloaking-rules.txt,forwarding-rules.txt}
-
- popd >/dev/null || die
-
- insinto /usr/share/dnscrypt-proxy
- doins -r "utils/generate-domains-blocklist/."
-
- newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
- newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
-
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/dnscrypt-proxy.logrotate dnscrypt-proxy
-
- einstalldocs
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if ! use filecaps; then
- ewarn "'filecaps' USE flag is disabled"
- ewarn "${PN} will fail to listen on port 53"
- ewarn "please do one the following:"
- ewarn "1) re-enable 'filecaps'"
- ewarn "2) change port to > 1024"
- ewarn "3) configure to run ${PN} as root (not recommended)"
- ewarn
- fi
-
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "Using systemd socket activation may cause issues with speed"
- elog "latency and reliability of ${PN} and is discouraged by upstream"
- elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
- elog "It is disabled by default for new installations"
- elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
- elog
-
- fi
-
- elog "After starting the service you will need to update your"
- elog "/etc/resolv.conf and replace your current set of resolvers"
- elog "with:"
- elog
- elog "nameserver 127.0.0.1"
- elog
- elog "Also see https://github.com/DNSCrypt/${PN}/wiki"
-}
diff --git a/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.1.0-config-full-paths.patch b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.1.0-config-full-paths.patch
deleted file mode 100644
index b0ab738a57e5..000000000000
--- a/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.1.0-config-full-paths.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff --git a/dnscrypt-proxy/example-dnscrypt-proxy.toml b/dnscrypt-proxy/example-dnscrypt-proxy.toml
-index e180a73..bc330dd 100644
---- a/dnscrypt-proxy/example-dnscrypt-proxy.toml
-+++ b/dnscrypt-proxy/example-dnscrypt-proxy.toml
-@@ -341,7 +341,7 @@ reject_ttl = 10
-
- ## See the `example-forwarding-rules.txt` file for an example
-
--# forwarding_rules = 'forwarding-rules.txt'
-+# forwarding_rules = '/etc/dnscrypt-proxy/forwarding-rules.txt'
-
-
-
-@@ -355,7 +355,7 @@ reject_ttl = 10
- ##
- ## See the `example-cloaking-rules.txt` file for an example
-
--# cloaking_rules = 'cloaking-rules.txt'
-+# cloaking_rules = '/etc/dnscrypt-proxy/cloaking-rules.txt'
-
- ## TTL used when serving entries in cloaking-rules.txt
-
-@@ -408,7 +408,7 @@ cache_neg_max_ttl = 600
- ## check for connectivity and captive portals, along with hard-coded
- ## IP addresses to return.
-
--# map_file = 'example-captive-portals.txt'
-+# map_file = '/etc/dnscrypt-proxy/example-captive-portals.txt'
-
-
-
-@@ -438,8 +438,8 @@ cache_neg_max_ttl = 600
- ## Certificate file and key - Note that the certificate has to be trusted.
- ## See the documentation (wiki) for more information.
-
--# cert_file = 'localhost.pem'
--# cert_key_file = 'localhost.pem'
-+# cert_file = '/etc/dnscrypt-proxy/localhost.pem'
-+# cert_key_file = '/etc/dnscrypt-proxy/localhost.pem'
-
-
-
-@@ -688,13 +688,13 @@ cache_neg_max_ttl = 600
-
- # [sources.'odoh-servers']
- # urls = ['https://raw.githubusercontent.com/DNSCrypt/dnscrypt-resolvers/master/v3/odoh-servers.md', 'https://download.dnscrypt.info/resolvers-list/v3/odoh-servers.md', 'https://ipv6.download.dnscrypt.info/resolvers-list/v3/odoh-servers.md', 'https://download.dnscrypt.net/resolvers-list/v3/odoh-servers.md']
-- # cache_file = 'odoh-servers.md'
-+ # cache_file = '/var/cache/dnscrypt-proxy/odoh-servers.md'
- # minisign_key = 'RWQf6LRCGA9i53mlYecO4IzT51TGPpvWucNSCh1CBM0QTaLn73Y7GFO3'
- # refresh_delay = 24
- # prefix = ''
- # [sources.'odoh-relays']
- # urls = ['https://raw.githubusercontent.com/DNSCrypt/dnscrypt-resolvers/master/v3/odoh-relays.md', 'https://download.dnscrypt.info/resolvers-list/v3/odoh-relays.md', 'https://ipv6.download.dnscrypt.info/resolvers-list/v3/odoh-relays.md', 'https://download.dnscrypt.net/resolvers-list/v3/odoh-relays.md']
-- # cache_file = 'odoh-relays.md'
-+ # cache_file = '/var/cache/dnscrypt-proxy/odoh-relays.md'
- # minisign_key = 'RWQf6LRCGA9i53mlYecO4IzT51TGPpvWucNSCh1CBM0QTaLn73Y7GFO3'
- # refresh_delay = 24
- # prefix = ''
-@@ -704,7 +704,7 @@ cache_neg_max_ttl = 600
- # [sources.quad9-resolvers]
- # urls = ['https://www.quad9.net/quad9-resolvers.md']
- # minisign_key = 'RWQBphd2+f6eiAqBsvDZEBXBGHQBJfeG6G+wJPPKxCZMoEQYpmoysKUN'
-- # cache_file = 'quad9-resolvers.md'
-+ # cache_file = '/var/cache/dnscrypt-proxy/quad9-resolvers.md'
- # prefix = 'quad9-'
-
- ## Another example source, with resolvers censoring some websites not appropriate for children
-@@ -712,7 +712,7 @@ cache_neg_max_ttl = 600
-
- # [sources.'parental-control']
- # urls = ['https://raw.githubusercontent.com/DNSCrypt/dnscrypt-resolvers/master/v3/parental-control.md', 'https://download.dnscrypt.info/resolvers-list/v3/parental-control.md', 'https://ipv6.download.dnscrypt.info/resolvers-list/v3/parental-control.md', 'https://download.dnscrypt.net/resolvers-list/v3/parental-control.md']
-- # cache_file = 'parental-control.md'
-+ # cache_file = '/var/cache/dnscrypt-proxy/parental-control.md'
- # minisign_key = 'RWQf6LRCGA9i53mlYecO4IzT51TGPpvWucNSCh1CBM0QTaLn73Y7GFO3'
-
-