summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2017-12-11 12:47:05 +0000
committerSven Wegener <swegener@gentoo.org>2017-12-11 12:47:32 +0000
commit39b7a541e663b27fd3029468402d60ea618e7259 (patch)
tree6122e263ec874daf5684a942fe901276972dc8e0 /net-dns
parentapp-office/libreoffice-bin-debug: Revision bump, gcc 6 and Python 2.6, bug 63... (diff)
downloadgentoo-39b7a541e663b27fd3029468402d60ea618e7259.tar.gz
gentoo-39b7a541e663b27fd3029468402d60ea618e7259.tar.bz2
gentoo-39b7a541e663b27fd3029468402d60ea618e7259.zip
net-dns/pdns-recursor: Version bump, security bug #639780
CVE-2017-15120 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.0.8.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index c9752e96db9e..41d623100561 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,2 +1,3 @@
DIST pdns-recursor-4.0.7.tar.bz2 1107546 BLAKE2B 3ccda73878599e3ade69e4dc6b0787e588a8403fb7cacfbe574409513b8723cbfd29a3c73d857120def801da60a4bedbc0f0c396e6642adb0287204cde301331 SHA512 0c8873adcce5ed9b41f161bc71635da23496b4ae48dbffff7dcdf9c5181e720f9aa94e18bd64e0dff9fa03eae8410dc93585a74d13f0c16d38b0d1c0f4146bb2
+DIST pdns-recursor-4.0.8.tar.bz2 1071831 BLAKE2B d9ab0dada8efa4b05c136650b9a2eab3aec4acab28ffb6da5bb4f627dc085b2c2d046d1f0dac5cf6e7054b47d76b8d7b95f56cc096b613891a4422b77e9abe9d SHA512 9886fccd3042904b7133e03a7b45479c8f2f57ecb33e4a043703b5e84816cd04a331503870e16030c86b353c1e14d9283dba767c1247e46ed6e14b7e0e93a5ef
DIST pdns-recursor-4.1.0.tar.bz2 1222751 BLAKE2B b2b5a7dee227b28eb3a1451a4d07cb1804e039e6b405c332f30fbb8df39f395906607f3c074b2469b01885b702d12e86e4ffd6114811404134c16956905c744f SHA512 1e4d70f3794005c3f45b2ec0ab580c3697e7de3096f3378b9b9d1cd53f10f95e577522ca9f634eb235b166f007e8a2bfa99f312ddf19f266ad4bb0965167fd7c
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.0.8.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.0.8.ebuild
new file mode 100644
index 000000000000..9d36d7629444
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.0.8.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs flag-o-matic eutils versionator
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libressl lua luajit protobuf systemd"
+REQUIRED_USE="?? ( lua luajit )"
+
+DEPEND="lua? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:= )
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ systemd? ( sys-apps/systemd:0= )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ $(use_enable systemd) \
+ $(use_with lua) \
+ $(use_with luajit) \
+ $(use_with protobuf)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=nobody/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r1 pdns-recursor
+
+ keepdir /var/lib/powerdns
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ version_compare ${old} 4.0.0-r1
+ [[ $? -eq 1 ]] || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}