summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2022-01-25 14:54:53 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-01-25 14:57:55 -0800
commit3a36dc3f702c86c53a7f71e5cbea5db0ec8c2a56 (patch)
tree9fc02b4f1d8debaa45ba361c7bbb7ab24790503d /net-dns
parentx11-terms/sakura: remove unused patch (diff)
downloadgentoo-3a36dc3f702c86c53a7f71e5cbea5db0ec8c2a56.tar.gz
gentoo-3a36dc3f702c86c53a7f71e5cbea5db0ec8c2a56.tar.bz2
gentoo-3a36dc3f702c86c53a7f71e5cbea5db0ec8c2a56.zip
net-dns/bind: Bump (bug #831919), add py310 (bug #830037)
Closes: https://bugs.gentoo.org/831919 Closes: https://bugs.gentoo.org/830037 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/Manifest1
-rw-r--r--net-dns/bind/bind-9.16.25.ebuild375
2 files changed, 376 insertions, 0 deletions
diff --git a/net-dns/bind/Manifest b/net-dns/bind/Manifest
index 00f721a461ab..1133804671df 100644
--- a/net-dns/bind/Manifest
+++ b/net-dns/bind/Manifest
@@ -2,4 +2,5 @@ DIST bind-9.16.15.tar.xz 5025688 BLAKE2B 8b0723d46f812793f5a52b1ddacf21fe28e183e
DIST bind-9.16.18.tar.xz 5023512 BLAKE2B 7766c1e6ab30ae42f0ba49d96fe0e2675e79aa01c48569d3cf5c122944319fbb88299a193ce06cc0aa67f6085fd80e29472fc7adc845e4bbb7ff6896dae87ed6 SHA512 6ba2f14324ebdc66d2a6d60e929fb47e170dd7662cf4b18ef3ad9da30a61b43c7d5539e931c483ab36e63ae0398aeed255fd672489fb332dccf182df9aa102f9
DIST bind-9.16.21.tar.xz 5057816 BLAKE2B bc7de285b45084a4904aee7c5c3042c7a2075968f19ed76b932c976f86f60bc8bf0d6cce8889a9adf7e807c8151bd6088ef1b2b00460a4d1cff7a74bb2221d43 SHA512 2cb71e50600fd7409ca7b7e2e9cf4ef6668b07faad7980ac8060e6a76f30a315182d75534ad1dcfb740c225cdf727b2bd6aa9ceb24ab77ffff09b7b5d6eaca2d
DIST bind-9.16.22.tar.xz 5059000 BLAKE2B c4853a8be268f9666f3677adf2e64c6d74f7df44d2dc05df544cead38c6c3b86489d25a66ccea6ce8ca89fa525a1848fe93a8aaa6bb1ee090aa189bf6aad40f3 SHA512 586fb4d5a656d6539033dcdfdd230b36465a2d2e6ada651c1f1548d062a9050e7a962af87e2a56931fe24c65586d29012d4a041dcddbb28f42b4d01fe291d9d1
+DIST bind-9.16.25.tar.xz 5086780 BLAKE2B cb62d0d4e25f508f1a77fae6a11ff144d2436346c45a936d572df4c843cd72ec81cffacd0a81dcb74eb73b8bca7d0762a5746baadda36f260b79b72eade24d18 SHA512 e43c0e59159d3a5642db051f3982d8767fb726426380c32960fefe4b9afd05708ed8f7e80a98b803a580b048e1a368c888e2dd5695fa5fcd7b8b75574a27cb62
DIST dyndns-samples.tbz2 22866 BLAKE2B 409890653c6536cb9c0e3ba809d2bfde0e0ae73a2a101b4f229b46c01568466bc022bbbc37712171adbd08c572733e93630feab95a0fcd1ac50a7d37da1d1108 SHA512 83b0bf99f8e9ff709e8e9336d8c5231b98a4b5f0c60c10792f34931e32cc638d261967dfa5a83151ec3740977d94ddd6e21e9ce91267b3e279b88affdbc18cac
diff --git a/net-dns/bind/bind-9.16.25.ebuild b/net-dns/bind/bind-9.16.25.ebuild
new file mode 100644
index 000000000000..98685833126f
--- /dev/null
+++ b/net-dns/bind/bind-9.16.25.ebuild
@@ -0,0 +1,375 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Re dlz/mysql and threads, needs to be verified..
+# MySQL uses thread local storage in its C api. Thus MySQL
+# requires that each thread of an application execute a MySQL
+# thread initialization to setup the thread local storage.
+# This is impossible to do safely while staying within the DLZ
+# driver API. This is a limitation caused by MySQL, and not the DLZ API.
+# Because of this BIND MUST only run with a single thread when
+# using the MySQL driver.
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-r1 autotools toolchain-funcs flag-o-matic db-use systemd tmpfiles
+
+MY_PV="${PV/_p/-P}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+SDB_LDAP_VER="1.1.0-fc14"
+
+RRL_PV="${MY_PV}"
+
+# SDB-LDAP: http://bind9-ldap.bayour.com/
+
+DESCRIPTION="Berkeley Internet Name Domain - Name Server"
+HOMEPAGE="https://www.isc.org/software/bind"
+SRC_URI="https://downloads.isc.org/isc/bind9/${PV}/${P}.tar.xz
+ doc? ( mirror://gentoo/dyndns-samples.tbz2 )"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+# -berkdb by default re bug 602682
+IUSE="berkdb +caps +dlz dnstap doc dnsrps fixed-rrset geoip geoip2 gssapi
+json ldap lmdb mysql odbc postgres python selinux static-libs xml +zlib"
+# sdb-ldap - patch broken
+# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
+
+# Upstream dropped the old geoip library, but the BIND configuration for using
+# GeoIP remained the same.
+REQUIRED_USE="
+ postgres? ( dlz )
+ berkdb? ( dlz )
+ mysql? ( dlz )
+ odbc? ( dlz )
+ ldap? ( dlz )
+ dnsrps? ( dlz )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+DEPEND="
+ acct-group/named
+ acct-user/named
+ berkdb? ( sys-libs/db:= )
+ dev-libs/openssl:=[-bindist(-)]
+ mysql? ( dev-db/mysql-connector-c:0= )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ ldap? ( net-nds/openldap )
+ postgres? ( dev-db/postgresql:= )
+ caps? ( >=sys-libs/libcap-2.1.0 )
+ xml? ( dev-libs/libxml2 )
+ geoip? ( dev-libs/libmaxminddb )
+ geoip2? ( dev-libs/libmaxminddb )
+ gssapi? ( virtual/krb5 )
+ json? ( dev-libs/json-c:= )
+ lmdb? ( dev-db/lmdb )
+ zlib? ( sys-libs/zlib )
+ dnstap? ( dev-libs/fstrm dev-libs/protobuf-c )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/ply[${PYTHON_USEDEP}]
+ )
+ dev-libs/libuv:=
+"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-bind )
+ sys-process/psmisc"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/ldap-library-path-on-multilib-machines.patch"
+)
+
+# bug 479092, requires networking
+# bug 710840, cmocka fails LDFLAGS='-Wl,-O1'
+#RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # should be installed by bind-tools
+ sed -i -r -e "s:(nsupdate|dig|delv) ::g" bin/Makefile.in || die
+
+ # Disable tests for now, bug 406399
+ sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
+
+ # bug #220361
+ rm aclocal.m4 || die
+ rm -rf libtool.m4/ || die
+ eautoreconf
+
+ use python && python_copy_sources
+}
+
+src_configure() {
+ bind_configure --without-python
+ use python && python_foreach_impl python_configure
+}
+
+bind_configure() {
+ local myeconfargs=(
+ AR="$(type -P $(tc-getAR))"
+ --prefix="${EPREFIX}"/usr
+ --sysconfdir=/etc/bind
+ --localstatedir=/var
+ --with-libtool
+ --enable-full-report
+ --without-readline
+ --with-openssl="${ESYSROOT}"/usr
+ --without-cmocka
+ # Removed in 9.17, drags in libunwind dependency too
+ --disable-backtrace
+ $(use_enable caps linux-caps)
+ $(use_enable dnsrps)
+ $(use_enable dnstap)
+ $(use_enable fixed-rrset)
+ # $(use_enable static-libs static)
+ $(use_with berkdb dlz-bdb "${ESYSROOT}"/usr)
+ $(use_with dlz dlopen)
+ $(use_with dlz dlz-filesystem)
+ $(use_with dlz dlz-stub)
+ $(use_with gssapi)
+ $(use_with json json-c)
+ $(use_with ldap dlz-ldap)
+ $(use_with mysql dlz-mysql)
+ $(use_with odbc dlz-odbc)
+ $(use_with postgres dlz-postgres)
+ $(use_with lmdb)
+ $(use_with xml libxml2)
+ $(use_with zlib)
+ "${@}"
+ )
+ # This is for users to start to migrate back to USE=geoip, rather than
+ # USE=geoip2
+ if use geoip ; then
+ myeconfargs+=( $(use_with geoip maxminddb) --enable-geoip )
+ elif use geoip2 ; then
+ # Added 2020/09/30
+ # Remove USE=geoip2 support after 2020/03/01
+ ewarn "USE=geoip2 is deprecated; update your USE flags!"
+ myeconfargs+=( $(use_with geoip2 maxminddb) --enable-geoip )
+ else
+ myeconfargs+=( --without-maxminddb --disable-geoip )
+ fi
+
+ # bug #158664
+# gcc-specs-ssp && replace-flags -O[23s] -O
+
+ # To include db.h from proper path
+ use berkdb && append-flags "-I$(db_includedir)"
+
+ export BUILD_CC=$(tc-getBUILD_CC)
+ econf "${myeconfargs[@]}"
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+python_configure() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+ bind_configure --with-python
+ popd >/dev/null || die
+}
+
+src_compile() {
+ default
+ use python && python_foreach_impl python_compile
+}
+
+python_compile() {
+ pushd "${BUILD_DIR}"/bin/python >/dev/null || die
+ emake
+ popd >/dev/null || die
+}
+
+src_install() {
+ default
+
+ dodoc CHANGES README
+
+ if use doc; then
+ docinto misc
+ dodoc -r doc/misc/
+
+ # might a 'html' useflag make sense?
+ docinto html
+ dodoc -r doc/arm/
+
+ docinto contrib
+ dodoc contrib/scripts/{nanny.pl,named-bootconf.sh}
+
+ # some handy-dandy dynamic dns examples
+ pushd "${ED}"/usr/share/doc/${PF} 1>/dev/null || die
+ tar xf "${DISTDIR}"/dyndns-samples.tbz2 || die
+ popd 1>/dev/null || die
+ fi
+
+ insinto /etc/bind
+ newins "${FILESDIR}"/named.conf-r8 named.conf
+
+ # ftp://ftp.rs.internic.net/domain/named.cache:
+ insinto /var/bind
+ newins "${FILESDIR}"/named.cache-r3 named.cache
+
+ insinto /var/bind/pri
+ newins "${FILESDIR}"/localhost.zone-r3 localhost.zone
+
+ newinitd "${FILESDIR}"/named.init-r14 named
+ newconfd "${FILESDIR}"/named.confd-r7 named
+
+ newenvd "${FILESDIR}"/10bind.env 10bind
+
+ # Let's get rid of those tools and their manpages since they're provided by bind-tools
+ rm -f "${ED}"/usr/share/man/man1/{dig,host,nslookup,delv,nsupdate}.1* || die
+ rm -f "${ED}"/usr/share/man/man8/nsupdate.8* || die
+ rm -f "${ED}"/usr/bin/{dig,host,nslookup,nsupdate} || die
+ rm -f "${ED}"/usr/sbin/{dig,host,nslookup,nsupdate} || die
+ for tool in dsfromkey importkey keyfromlabel keygen \
+ revoke settime signzone verify; do
+ rm -f "${ED}"/usr/{,s}bin/dnssec-"${tool}" || die
+ rm -f "${ED}"/usr/share/man/man8/dnssec-"${tool}".8* || die
+ done
+
+ # bug 405251, library archives aren't properly handled by --enable/disable-static
+ if ! use static-libs; then
+ find "${ED}" -type f -name '*.a' -delete || die
+ fi
+
+ # bug 405251
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ use python && python_foreach_impl python_install
+
+ # bug 450406
+ dosym named.cache /var/bind/root.cache
+
+ dosym ../../var/bind/pri /etc/bind/pri
+ dosym ../../var/bind/sec /etc/bind/sec
+ dosym ../../var/bind/dyn /etc/bind/dyn
+ keepdir /var/bind/{pri,sec,dyn} /var/log/named
+
+ fowners root:named /{etc,var}/bind /var/log/named /var/bind/{sec,pri,dyn}
+ fowners root:named /var/bind/named.cache /var/bind/pri/localhost.zone /etc/bind/{bind.keys,named.conf}
+ fperms 0640 /var/bind/named.cache /var/bind/pri/localhost.zone /etc/bind/{bind.keys,named.conf}
+ fperms 0750 /etc/bind /var/bind/pri
+ fperms 0770 /var/log/named /var/bind/{,sec,dyn}
+
+ systemd_newunit "${FILESDIR}/named.service-r1" named.service
+ dotmpfiles "${FILESDIR}"/named.conf
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/generate-rndc-key.sh"
+}
+
+python_install() {
+ pushd "${BUILD_DIR}"/bin/python >/dev/null || die
+ emake DESTDIR="${D}" install
+ python_scriptinto /usr/sbin
+ python_doscript dnssec-{checkds,coverage}
+ python_optimize
+ popd >/dev/null || die
+}
+
+pkg_postinst() {
+ tmpfiles_process named.conf
+
+ if [[ ! -f '/etc/bind/rndc.key' && ! -f '/etc/bind/rndc.conf' ]]; then
+ einfo "Using /dev/urandom for generating rndc.key"
+ /usr/sbin/rndc-confgen -a
+ chown root:named /etc/bind/rndc.key || die
+ chmod 0640 /etc/bind/rndc.key || die
+ fi
+
+ einfo
+ einfo "You can edit /etc/conf.d/named to customize named settings"
+ einfo
+ use mysql || use postgres || use ldap && {
+ elog "If your named depends on MySQL/PostgreSQL or LDAP,"
+ elog "uncomment the specified rc_named_* lines in your"
+ elog "/etc/conf.d/named config to ensure they'll start before bind"
+ einfo
+ }
+ einfo "If you'd like to run bind in a chroot AND this is a new"
+ einfo "install OR your bind doesn't already run in a chroot:"
+ einfo "1) Uncomment and set the CHROOT variable in /etc/conf.d/named."
+ einfo "2) Run \`emerge --config '=${CATEGORY}/${PF}'\`"
+ einfo
+
+ CHROOT=$(source /etc/conf.d/named 2>/dev/null; echo ${CHROOT})
+ if [[ -n ${CHROOT} ]]; then
+ elog "NOTE: As of net-dns/bind-9.4.3_p5-r1 the chroot part of the init-script got some major changes!"
+ elog "To enable the old behaviour (without using mount) uncomment the"
+ elog "CHROOT_NOMOUNT option in your /etc/conf.d/named config."
+ elog "If you decide to use the new/default method, ensure to make backup"
+ elog "first and merge your existing configs/zones to /etc/bind and"
+ elog "/var/bind because bind will now mount the needed directories into"
+ elog "the chroot dir."
+ fi
+}
+
+pkg_config() {
+ CHROOT=$(source /etc/conf.d/named; echo ${CHROOT})
+ CHROOT_NOMOUNT=$(source /etc/conf.d/named; echo ${CHROOT_NOMOUNT})
+ CHROOT_GEOIP=$(source /etc/conf.d/named; echo ${CHROOT_GEOIP})
+
+ if [[ -z "${CHROOT}" ]]; then
+ eerror "This config script is designed to automate setting up"
+ eerror "a chrooted bind/named. To do so, please first uncomment"
+ eerror "and set the CHROOT variable in '/etc/conf.d/named'."
+ die "Unset CHROOT"
+ fi
+ if [[ -d "${CHROOT}" ]]; then
+ ewarn "NOTE: As of net-dns/bind-9.4.3_p5-r1 the chroot part of the init-script got some major changes!"
+ ewarn "To enable the old behaviour (without using mount) uncomment the"
+ ewarn "CHROOT_NOMOUNT option in your /etc/conf.d/named config."
+ ewarn
+ ewarn "${CHROOT} already exists... some things might become overridden"
+ ewarn "press CTRL+C if you don't want to continue"
+ sleep 10
+ fi
+
+ echo; einfo "Setting up the chroot directory..."
+
+ mkdir -m 0750 -p ${CHROOT} || die
+ mkdir -m 0755 -p ${CHROOT}/{dev,etc,var/log,run} || die
+ mkdir -m 0750 -p ${CHROOT}/etc/bind || die
+ mkdir -m 0770 -p ${CHROOT}/var/{bind,log/named} ${CHROOT}/run/named/ || die
+
+ chown root:named \
+ ${CHROOT} \
+ ${CHROOT}/var/{bind,log/named} \
+ ${CHROOT}/run/named/ \
+ ${CHROOT}/etc/bind \
+ || die
+
+ mknod ${CHROOT}/dev/null c 1 3 || die
+ chmod 0666 ${CHROOT}/dev/null || die
+
+ mknod ${CHROOT}/dev/zero c 1 5 || die
+ chmod 0666 ${CHROOT}/dev/zero || die
+
+ mknod ${CHROOT}/dev/urandom c 1 9 || die
+ chmod 0666 ${CHROOT}/dev/urandom || die
+
+ if [ "${CHROOT_NOMOUNT:-0}" -ne 0 ]; then
+ cp -a /etc/bind ${CHROOT}/etc/ || die
+ cp -a /var/bind ${CHROOT}/var/ || die
+ fi
+
+ if [ "${CHROOT_GEOIP:-0}" -eq 1 ]; then
+ if use geoip; then
+ mkdir -m 0755 -p ${CHROOT}/usr/share/GeoIP || die
+ elif use geoip2; then
+ mkdir -m 0755 -p ${CHROOT}/usr/share/GeoIP2 || die
+ fi
+ fi
+
+ elog "You may need to add the following line to your syslog-ng.conf:"
+ elog "source jail { unix-stream(\"${CHROOT}/dev/log\"); };"
+}