summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2022-01-22 19:19:22 +0100
committerSven Wegener <swegener@gentoo.org>2022-01-22 19:23:22 +0100
commit4dab1ff19fd2e461587c66c81db0e76321b24bce (patch)
tree074b5ad60c9e119ce2f63e80c3254f2576f979b0 /net-dns
parentmail-mta/ssmtp: Drop ~ia64 keyword (diff)
downloadgentoo-4dab1ff19fd2e461587c66c81db0e76321b24bce.tar.gz
gentoo-4dab1ff19fd2e461587c66c81db0e76321b24bce.tar.bz2
gentoo-4dab1ff19fd2e461587c66c81db0e76321b24bce.zip
net-dns/pdns: Version bump to 4.5.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/Manifest1
-rw-r--r--net-dns/pdns/pdns-4.5.3.ebuild167
2 files changed, 168 insertions, 0 deletions
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index f82496b1dc0b..eb75caeaeb8d 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,3 +1,4 @@
DIST pdns-4.4.1.tar.bz2 1276990 BLAKE2B 9771cf3273ab7e8ab4607a91563bfe0dc3f4532b5420861d816eacd2798d66de3a1eb824c191264f9106ec47bd6003d99108b8df678190055948779b9b3b070f SHA512 a6f31972f77ded8ecfb523e8810dd90e5b7aa628746fee2a9a0daae2a7935800f111ce8617ffd71d5ce3881947d4ffc36c9cb37996a7bcc514536bb4abe1f79e
DIST pdns-4.4.2.tar.bz2 1273410 BLAKE2B 71c6bdf9e6253babb69e221b7fbc9e500dc92cdd8ba14a1ec2b22986355663f66ddb72579dde42eb4532206263e74a874ea1ce23b3407a019c30b9ca10a2f04a SHA512 cf96a55179f19f75972bcd636b858c9d112662d0007b8895deeea7737f6f348d4318ecb5d2c2e77f66d1af82575a0f9a3207e16da1e70fc8bb316226f9252205
DIST pdns-4.5.2.tar.bz2 1266572 BLAKE2B 9bd3d391e32c4040cc916003a45d47784ea309dd43a326919e2ca5415e1a1c542d5937cf1570951a4100a524a933aa9c0114ef8e28957f64acb6f7a7fa18e237 SHA512 0a183d8c0bb517799afa0f9382e3c06ad3c6e9c871b7912073a860364ca97dc121be2372080100677db10601c8ef96ad56b10787c02a9a9ede82f8a1cc904c6e
+DIST pdns-4.5.3.tar.bz2 1265929 BLAKE2B 49425dd65bc2ea1ceaba5349db828b8e7e0031f7327bc867235fe293a107cebae69f734731a21369616ce2a5121309490556ba7838a91a9cabb74a6f0d4e42c0 SHA512 9708f69ed045c801e5cbc5d62f57532ad461f1e9e4574fe2b5d5f72e8534587cfc28f55afaaa1a52f59d7feb8331a683b3f5db7e896d01002996321598550607
diff --git a/net-dns/pdns/pdns-4.5.3.ebuild b/net-dns/pdns/pdns-4.5.3.ebuild
new file mode 100644
index 000000000000..b5bfd57800c4
--- /dev/null
+++ b/net-dns/pdns/pdns-4.5.3.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# other possible flags:
+# db2: we lack the dep
+# oracle: dito (need Oracle Client Libraries)
+# xdb: (almost) dead, surely not supported
+
+IUSE="debug doc geoip ldap lua-records mydns mysql postgres remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ mydns? ( mysql )"
+
+DEPEND="${LUA_DEPS}
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:=
+ lua-records? ( >=net-misc/curl-7.21.3 )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 app-crypt/mit-krb5 )
+ sqlite? ( dev-db/sqlite:3 )
+ geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
+ sodium? ( dev-libs/libsodium:= )
+ tinydns? ( >=dev-db/tinycdb-0.77 )"
+RDEPEND="${DEPEND}
+ acct-user/pdns
+ acct-group/pdns"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ local dynmodules="pipe bind" # the default backends, always enabled
+
+ #use db2 && dynmodules+=" db2"
+ use ldap && dynmodules+=" ldap"
+ use mydns && dynmodules+=" mydns"
+ use mysql && dynmodules+=" gmysql"
+ #use oracle && dynmodules+=" goracle oracle"
+ use postgres && dynmodules+=" gpgsql"
+ use remote && dynmodules+=" remote"
+ use sqlite && dynmodules+=" gsqlite3"
+ use tinydns && dynmodules+=" tinydns"
+ use geoip && dynmodules+=" geoip"
+ #use xdb && dynmodules+=" xdb"
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-modules= \
+ --with-dynmodules="${dynmodules}" \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable lua-records) \
+ $(use_enable test unit-tests) \
+ $(use_enable tools) \
+ $(use_enable systemd) \
+ $(use_with sodium libsodium) \
+ ${myconf}
+}
+
+src_compile() {
+ default
+ use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ fperms 0700 /etc/powerdns
+ fperms 0600 /etc/powerdns/pdns.conf
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ newinitd "${FILESDIR}"/pdns-r1 pdns
+
+ keepdir /var/empty
+
+ if use doc; then
+ docinto html
+ dodoc -r codedocs/html/.
+ fi
+
+ # Install development headers
+ insinto /usr/include/pdns
+ doins pdns/*.hh
+ insinto /usr/include/pdns/backends/gsql
+ doins pdns/backends/gsql/*.hh
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/dnsdomain2.schema
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "PowerDNS provides multiple instances support. You can create more instances"
+ elog "by symlinking the pdns init script to another name."
+ elog
+ elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+ elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+ local old
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 3.2 || continue
+
+ echo
+ ewarn "To fix a security bug (bug #458018) had the following"
+ ewarn "files/directories the world-readable bit removed (if set):"
+ ewarn " ${EPREFIX}/etc/powerdns"
+ ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
+ ewarn "Check if this is correct for your setup"
+ ewarn "This is a one-time change and will not happen on subsequent updates."
+ chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+ break
+ done
+
+ if use postgres; then
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.1.11-r1 || continue
+
+ echo
+ ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+ ewarn "This security fix needs to be applied manually to the database schema."
+ ewarn "Please refer to the official security advisory for more information:"
+ ewarn
+ ewarn " https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+ break
+ done
+ fi
+}