summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2021-12-01 00:35:17 -1000
committerMarc Schiffbauer <mschiff@gentoo.org>2021-12-01 00:36:41 -1000
commit5432f54434616786c4e10a090793bb0f5afd684e (patch)
treec67954bb9d9684f4ca522083884fd88dfb061605 /net-dns
parentnet-libs/ldns: add 1.8.0 (diff)
downloadgentoo-5432f54434616786c4e10a090793bb0f5afd684e.tar.gz
gentoo-5432f54434616786c4e10a090793bb0f5afd684e.tar.bz2
gentoo-5432f54434616786c4e10a090793bb0f5afd684e.zip
net-dns/ldns-utils: add 1.8.0
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ldns-utils/Manifest1
-rw-r--r--net-dns/ldns-utils/ldns-utils-1.8.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-dns/ldns-utils/Manifest b/net-dns/ldns-utils/Manifest
index 13e5bc23ba61..a296b9b972ad 100644
--- a/net-dns/ldns-utils/Manifest
+++ b/net-dns/ldns-utils/Manifest
@@ -1 +1,2 @@
DIST ldns-1.7.1.tar.gz 1244394 BLAKE2B 8f2d9c6e34c4f13924ce1531a5757c4a619fc31ebc5a0a3d4aaf43fcfc8b53e8f371984b1c60ab74f735a05a9ca0710fc29a40fffeaef66eb54395eb3a727a0d SHA512 e8f72a4ff4aa544acac5e7be9a8ba38c6b8d388bb26f9a0ed04c1a921622f8582cc8539beafc76a29187a55c94069b7c1875e77522e1a7e7bb3e297dd1e4c2b7
+DIST ldns-1.8.0.tar.gz 1283220 BLAKE2B f916a8c76d788ac7c52aea8bfe675ad4c614a0c6fb011b61f5a27d4a5dc1a2adb33b5c6992b4813b3758c9b7cceab1c77f8c1d66baaa4de993f23888bce69df1 SHA512 54b306160bb7fd76d181f4be0a13134017f6f98ae96e0c954409f31f262e9dbe611c4b76fb6dff47bb6155c652ed8d026b52a50dfcf611e54d9c204b314c4fd6
diff --git a/net-dns/ldns-utils/ldns-utils-1.8.0.ebuild b/net-dns/ldns-utils/ldns-utils-1.8.0.ebuild
new file mode 100644
index 000000000000..b0313d3adfbd
--- /dev/null
+++ b/net-dns/ldns-utils/ldns-utils-1.8.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/-utils}
+
+DESCRIPTION="Set of utilities to simplify various dns(sec) tasks"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/ldns/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="+dane ecdsa ed25519 ed448 examples gost ssl"
+
+REQUIRED_USE="
+ ecdsa? ( ssl )
+ ed25519? ( ssl )
+ ed448? ( ssl )
+ dane? ( ssl )
+ gost? ( ssl )
+"
+
+DEPEND=">=net-libs/ldns-${PV}[dane?,ecdsa?,ed25519?,ed448?,gost?]
+ examples? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # >=openssl-1.1.0 required for dane-ta
+ if has_version "<dev-libs/openssl-1.1.0" ; then
+ local dane_ta_usage="--disable-dane-ta-usage"
+ else
+ local dane_ta_usage=""
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --with-drill \
+ $(use_with ssl) \
+ $(use_with examples) \
+ $(use_enable dane) \
+ $(use_enable ecdsa) \
+ $(use_enable ed25519) \
+ $(use_enable ed448) \
+ $(use_enable gost) \
+ $(use_enable ssl sha2) \
+ $dane_ta_usage
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ #cd "${S}"/drill
+ emake DESTDIR="${D}" install-drill
+ dodoc drill/{ChangeLog.22-nov-2005,README,REGRESSIONS}
+
+ if use examples; then
+ emake DESTDIR="${D}" install-examples
+ newdoc examples/README README.examples
+ fi
+}