summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-01-16 17:24:34 +0100
committerSam James <sam@gentoo.org>2023-01-17 01:52:14 +0000
commit58abf73ae11459c9d6c93c0e2c2aa4b0063253aa (patch)
treead14ca8fd11fcb8d14c1303e0704ed627bee7617 /net-dns
parentsys-apps/s6-linux-init: add 1.0.8.1 (diff)
downloadgentoo-58abf73ae11459c9d6c93c0e2c2aa4b0063253aa.tar.gz
gentoo-58abf73ae11459c9d6c93c0e2c2aa4b0063253aa.tar.bz2
gentoo-58abf73ae11459c9d6c93c0e2c2aa4b0063253aa.zip
net-dns/s6-dns: add 2.3.5.5
The --disable-static needs to be explicitly specified in configuration phase otherwise static libraries are created. Fixes: d173f866c22b ("net-dns/s6-dns: drop IUSE="static static-libs"") Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/s6-dns/Manifest1
-rw-r--r--net-dns/s6-dns/s6-dns-2.3.5.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-dns/s6-dns/Manifest b/net-dns/s6-dns/Manifest
index 185633f52ee2..f1b52237dee1 100644
--- a/net-dns/s6-dns/Manifest
+++ b/net-dns/s6-dns/Manifest
@@ -1 +1,2 @@
DIST s6-dns-2.3.5.4.tar.gz 84892 BLAKE2B 3bba411b297b85fdf5da7caf251b3c093d0e7108fdf16321e510a485e750ef37c6ec1a923e627a81a9719f211e2e284c9b8d3bcf60a4e18738d0886f931e380d SHA512 04c8fd40c71c9517f4e8d847a0ddf7d60a7759b4d7075035c2e00b4eb34e81edf4608df562929042c294ed671ab953e613374b577210ff49841ceb27dd563ae5
+DIST s6-dns-2.3.5.5.tar.gz 86083 BLAKE2B 2c75c1b8eebb8ad8a95117962725ad49c89449a0bf3f117db2cf117e6ba10ad731c96b329ded8103ef71a654e545ebb1a3b6f60e5ddfc4080870b115e8c1d2a3 SHA512 7d7435da8fab3dd8f872c4dd90338fae2b817b4cb1e4715cc86d77b4c1f58e931bdeb1385093f6bd6293951f97f765fb6372af5560042ae84b5bd53ecc2645c2
diff --git a/net-dns/s6-dns/s6-dns-2.3.5.5.ebuild b/net-dns/s6-dns/s6-dns-2.3.5.5.ebuild
new file mode 100644
index 000000000000..c4dacb90602e
--- /dev/null
+++ b/net-dns/s6-dns/s6-dns-2.3.5.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Suite of DNS client programs and libraries for Unix systems"
+HOMEPAGE="https://www.skarnet.org/software/s6-dns/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/skalibs-2.13.0.0:="
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ )
+
+ econf "${myconf[@]}"
+}