summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2021-08-10 13:13:27 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-08-10 15:01:51 +0200
commit66b1d9879c8ef027bef014d3992c8b8f49078f79 (patch)
tree74da1d5c593c33d2d86663ad907691837d146bd1 /net-dns
parentsci-libs/djbfft: update EAPI 5 -> 8 (diff)
downloadgentoo-66b1d9879c8ef027bef014d3992c8b8f49078f79.tar.gz
gentoo-66b1d9879c8ef027bef014d3992c8b8f49078f79.tar.bz2
gentoo-66b1d9879c8ef027bef014d3992c8b8f49078f79.zip
net-dns/knot: bump to 3.1.1
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/Manifest1
-rw-r--r--net-dns/knot/knot-3.1.1.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index e3d9f53353ca..70ac340a2d60 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -2,3 +2,4 @@ DIST knot-2.9.8.tar.xz 1194284 BLAKE2B c4329e5b2fc499851112d008af10c1a73bbe50cd0
DIST knot-3.0.4.tar.xz 1347928 BLAKE2B c97df0c04dbd6b96d2f2805a2bbb07bc3fd0ac64160619a55fdf93ac02e6d3f797dfae43ac8bc79450c59c88e0a521911517577ea19d67bb41186cfcd07dd743 SHA512 d674faaafcbe882539d28e53f1cd6cdda61ca8065f66dc0b9127f249f34b59a9d3d1ac206799c2974a2d38264842a2387db35f814bd05f3eaeac0b35b90b21ac
DIST knot-3.0.6.tar.xz 1333296 BLAKE2B 74ee1133dbf954234c4b07a29986cb91363256f3450b3d270f6d458d723e89bd1f7434881aa51632f02c369a16ca461e8ab892c34a2cf2ed612aa9040c91d535 SHA512 f1bfb0bc3a4cf622a68562409e71c8b84ee628a5452b48e172148bcac9cd0827b60a0c060075b80a086ca65da958d2d63e33ef7e373ab300b50089d06af3e5d0
DIST knot-3.0.7.tar.xz 1334788 BLAKE2B 0ac740b25912ae84714e078963880c27082f8d0e668f0df3b04a6a8a3588d0ffaf0ded9f6e3dd64cf9bc0b08673219e32ac3ffb86f64b9ea97cb61ab9cb545d4 SHA512 89e17cd2bc5a07b05ccd11cfd58481078eff4076a537d1623ed575c1ab87eac87ce949c12dc35eb15dc7e4358a405c19a6660b4da9abc230077a251792f196bd
+DIST knot-3.1.1.tar.xz 1402352 BLAKE2B d6f9d29de153b5bdea8a294ae3d65131a0bdcc339ecdc507a9e1429a9cc50752e91f14ea84a7446de76869c6f129d571e9b6b4f9b048618941c4f4c0d667dbff SHA512 44c2973025e752f73ebd6bc78dad5c48c1c1432b62ec3b6d75b5876af4dd21aeed94f78523ef85cd6a986ff27789143a0a67450819c0b75ffa627d06b98e1b0b
diff --git a/net-dns/knot/knot-3.1.1.ebuild b/net-dns/knot/knot-3.1.1.ebuild
new file mode 100644
index 000000000000..b4082a371f4a
--- /dev/null
+++ b/net-dns/knot/knot-3.1.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic systemd
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+KNOT_MODULES=(
+ "+cookies"
+ "+dnsproxy"
+ "dnstap"
+ "geoip"
+ "+noudp"
+ "+onlinesign"
+ "+queryacl"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ acct-group/knot
+ acct-user/knot
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu:=
+ dev-python/lmdb
+ net-libs/gnutls:=
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c:=
+ )
+ geoip? ( dev-libs/libmaxminddb:= )
+ idn? (
+ !libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
+ libidn2? ( net-dns/libidn2:= )
+ )
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ if use riscv; then
+ append-libs -latomic
+ fi
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+
+ default
+
+ rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}