summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-07 12:20:12 +0100
committerSam James <sam@gentoo.org>2023-06-07 12:20:12 +0100
commit6e9437e116b0186d464b1fe48f9ff7f0617e71fd (patch)
tree44a83d7b11f5974c915fae8e6751c7ef8320f187 /net-dns
parentwww-client/firefox: move mold check to src_compile in 114 (diff)
downloadgentoo-6e9437e116b0186d464b1fe48f9ff7f0617e71fd.tar.gz
gentoo-6e9437e116b0186d464b1fe48f9ff7f0617e71fd.tar.bz2
gentoo-6e9437e116b0186d464b1fe48f9ff7f0617e71fd.zip
net-dns/nsd: fix build w/ USE='-bind8-stats -ssl'
Closes: https://bugs.gentoo.org/907997 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/nsd/files/nsd-4.7.0-no-bind8-stats-no-ssl.patch23
-rw-r--r--net-dns/nsd/nsd-4.7.0.ebuild2
2 files changed, 25 insertions, 0 deletions
diff --git a/net-dns/nsd/files/nsd-4.7.0-no-bind8-stats-no-ssl.patch b/net-dns/nsd/files/nsd-4.7.0-no-bind8-stats-no-ssl.patch
new file mode 100644
index 000000000000..402a42e19e0c
--- /dev/null
+++ b/net-dns/nsd/files/nsd-4.7.0-no-bind8-stats-no-ssl.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/907997
+https://github.com/NLnetLabs/nsd/issues/283
+https://github.com/NLnetLabs/nsd/commit/f31d31ab1d45d615ebd192beaacac66746e0ff80
+
+From f31d31ab1d45d615ebd192beaacac66746e0ff80 Mon Sep 17 00:00:00 2001
+From: "W.C.A. Wijngaards" <wouter@nlnetlabs.nl>
+Date: Wed, 7 Jun 2023 13:07:53 +0200
+Subject: [PATCH] - Fix #283: Compile failure in remote.c when
+ --disable-bind8-stats
+
+--- a/remote.c
++++ b/remote.c
+@@ -1246,7 +1246,9 @@ do_stats(struct daemon_remote* rc, int peek, struct rc_state* rs)
+ xfrd_set_reload_now(xfrd);
+ #else
+ RES res;
++#ifdef HAVE_SSL
+ res.ssl = rs->ssl;
++#endif
+ res.fd = rs->fd;
+ (void)rc; (void)peek;
+ (void)ssl_printf(&res, "error no stats enabled at compile time\n");
+
diff --git a/net-dns/nsd/nsd-4.7.0.ebuild b/net-dns/nsd/nsd-4.7.0.ebuild
index d9028ba457da..6c6eb84db034 100644
--- a/net-dns/nsd/nsd-4.7.0.ebuild
+++ b/net-dns/nsd/nsd-4.7.0.ebuild
@@ -51,6 +51,8 @@ BDEPEND="
PATCHES=(
# Fix the paths in the munin plugin to match our install
"${FILESDIR}"/nsd_munin_.patch
+ # bug #907997
+ "${FILESDIR}"/${P}-no-bind8-stats-no-ssl.patch
)
src_prepare() {