summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-04-30 00:41:46 +0100
committerSam James <sam@gentoo.org>2021-05-04 22:17:10 +0000
commit6f91d81f5e55ca9b74942e1808173c111c69dbf9 (patch)
tree261beb06cd944b5f33626d9833ed5c6763f353df /net-dns
parentnet-analyzer/hunt: Respect CFLAGS (diff)
downloadgentoo-6f91d81f5e55ca9b74942e1808173c111c69dbf9.tar.gz
gentoo-6f91d81f5e55ca9b74942e1808173c111c69dbf9.tar.bz2
gentoo-6f91d81f5e55ca9b74942e1808173c111c69dbf9.zip
net-dns/maradns: Respect CFLAGS/LDFLAGS
Closes: https://bugs.gentoo.org/724942 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/maradns/files/maradns-3.5.0005-flags.patch28
-rw-r--r--net-dns/maradns/maradns-3.5.0005.ebuild21
2 files changed, 41 insertions, 8 deletions
diff --git a/net-dns/maradns/files/maradns-3.5.0005-flags.patch b/net-dns/maradns/files/maradns-3.5.0005-flags.patch
new file mode 100644
index 000000000000..66493632df0a
--- /dev/null
+++ b/net-dns/maradns/files/maradns-3.5.0005-flags.patch
@@ -0,0 +1,28 @@
+--- a/build/Makefile.linux
++++ b/build/Makefile.linux
+@@ -24,13 +24,13 @@ EXECS=server/maradns
+ # end the Solaris section
+ # Non-Solaris version of "M"
+ V="VERSION=$(VERSION)"
+-Q="DEFINES=-DSELECT_PROBLEM"
++Q="$(LDFLAGS) DEFINES=-DSELECT_PROBLEM"
+
+ # Debug
+
+ FLAGS = -O2 -Wall -DSELECT_PROBLEM
+-M="CC=$(CC) $(FLAGS)"
+-D="CC=$(CC) $(FLAGS) -DDEBUG -DTHREADS"
++M="CC=$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)"
++D="CC=$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -DDEBUG -DTHREADS"
+ #FLAGS = -g
+
+ all:
+@@ -39,7 +39,7 @@ all:
+ cd ../qual ; make $(M) ; cd ../server ; \
+ make $(M) $(V) COMPILED=\"$(COMPILED)\" ; \
+ cd ../tools ; make $(M) ; \
+- cd ../deadwood-*/src/ ; make FLAGS=-O2 ; \
++ cd ../deadwood-*/src/ ; $(MAKE) $(M) ; \
+ cd ../../tcp ; make $(M) $(V) ; cat ../00README.FIRST
+
+ debug:
diff --git a/net-dns/maradns/maradns-3.5.0005.ebuild b/net-dns/maradns/maradns-3.5.0005.ebuild
index dc945dfceb0f..13c34daf2065 100644
--- a/net-dns/maradns/maradns-3.5.0005.ebuild
+++ b/net-dns/maradns/maradns-3.5.0005.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8} )
-
-inherit systemd toolchain-funcs python-any-r1
+inherit python-any-r1 systemd toolchain-funcs
DESCRIPTION="A security-aware DNS server"
HOMEPAGE="http://www.maradns.org/"
@@ -17,12 +16,17 @@ SLOT="0"
KEYWORDS="amd64 ~mips ~ppc x86"
IUSE="examples ipv6"
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- acct-user/maradns
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/perl"
+DEPEND="
acct-group/maradns
acct-user/duende
- dev-lang/perl"
+ acct-user/maradns"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+)
src_prepare() {
default
@@ -36,7 +40,8 @@ src_prepare() {
src_configure() {
tc-export CC
- ./configure $(use ipv6 && echo "--ipv6") || die "Failed to configure ${PN}"
+ ./configure \
+ $(usex ipv6 --ipv6 "") || die "Failed to configure ${PN}"
}
src_install() {