summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2022-01-22 15:02:36 +0100
committerAndreas Schuerch <nativemad@gentoo.org>2022-01-22 15:02:36 +0100
commit706f140d6b150ec3a0e1fcb718685edeb440146a (patch)
tree6f2a785d00b11ba2d9073163ca3ff089dc27a7ce /net-dns
parentdev-ml/camlidl: do not call ar directly (diff)
downloadgentoo-706f140d6b150ec3a0e1fcb718685edeb440146a.tar.gz
gentoo-706f140d6b150ec3a0e1fcb718685edeb440146a.tar.bz2
gentoo-706f140d6b150ec3a0e1fcb718685edeb440146a.zip
net-dns/dnsdist: version bump to 1.7.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsdist/Manifest1
-rw-r--r--net-dns/dnsdist/dnsdist-1.7.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-dns/dnsdist/Manifest b/net-dns/dnsdist/Manifest
index c3dd19a29e1f..bea7732ff2ea 100644
--- a/net-dns/dnsdist/Manifest
+++ b/net-dns/dnsdist/Manifest
@@ -1,3 +1,4 @@
DIST dnsdist-1.5.1.tar.bz2 1068061 BLAKE2B 1c0fdd181b62b96fcd433581715cea9dc204fcdd2f65efd26a5293cc9c17d904e0937b51ba33d2dc01ecc8044f491ba2c6c8720c0816587fa5082da73108783e SHA512 68fe5f55fd081ed80a620933af9f8310be0e21c86ba449a9c557975b5c83f4b64e3002e6032dc002582d081e70e1ec2ff080c5d8389fd46a9896bdafd5a41f9f
DIST dnsdist-1.6.0.tar.bz2 1328707 BLAKE2B d093142875882cacaa456d76d42e703e45577c32a0e5d5024fb372180d2bdd4ff0c82546142f6c2c01904bdd15407f0a39dc1d658e04e171cffe386cfc1e943d SHA512 f6a1676c431d5622af075bc184c9f82b4ea0bb40ec84797a8fe835804f91bc0a93a745495f193bb52f3a5204ec0e98ed41bc206c997d1f5b13e872bb31747b0f
DIST dnsdist-1.6.1.tar.bz2 1328069 BLAKE2B a9e9c0cb35ebc2ecd93d7fa0d6d3961b02d711da2df56240335786a5d2e529d4a7e8716f578b6e935edd3bc79dfed767d358b9feaff32dd9cd65993ef0b97b71 SHA512 68e114eeb1a7ae8a4ce52a7de31095c46d0ba8f572676a8ef1e858b97da199c04ec88656c7642160ba07b7db325cc2a49cd91794da8dd2e81a5301d089c34f90
+DIST dnsdist-1.7.0.tar.bz2 1392585 BLAKE2B 3766da5f63df6390f555307d665efcbb2ad1462abae3af44503479d4c6ae6453e43527d2bcac718fabeb8b60ec989f264860532b480c465afc440405f9efac74 SHA512 abaed7aaa18f4acaf220dc938da6896e521373b1da3b6b9c4114467dd5d8b0e6cd9809534edbc6ba5b789ed8387fb47317c47bd4e00e66a6ccb035f6dd6068af
diff --git a/net-dns/dnsdist/dnsdist-1.7.0.ebuild b/net-dns/dnsdist/dnsdist-1.7.0.ebuild
new file mode 100644
index 000000000000..2500a331c58d
--- /dev/null
+++ b/net-dns/dnsdist/dnsdist-1.7.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="A highly DNS-, DoS- and abuse-aware loadbalancer"
+HOMEPAGE="https://dnsdist.org"
+
+SRC_URI="https://downloads.powerdns.com/releases/${P}.tar.bz2"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dnscrypt dnstap doh gnutls +lmdb regex remote-logging snmp +ssl systemd test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ dnscrypt? ( ssl )
+ gnutls? ( ssl )
+ doh? ( ssl !gnutls )"
+
+RDEPEND="acct-group/dnsdist
+ acct-user/dnsdist
+ >=dev-libs/boost-1.35:=
+ dev-libs/libedit:=
+ >=dev-libs/protobuf-3:=
+ dnscrypt? ( dev-libs/libsodium:= )
+ dnstap? ( dev-libs/fstrm:= )
+ doh? ( www-servers/h2o:=[libh2o] )
+ lmdb? ( dev-db/lmdb:= )
+ regex? ( dev-libs/re2:= )
+ snmp? ( net-analyzer/net-snmp:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+ systemd? ( sys-apps/systemd:0= )
+ ${LUA_DEPS}
+ net-libs/nghttp2
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/dnsdist \
+ --with-lua="${ELUA}" \
+ $(use_enable doh dns-over-https) \
+ $(use_enable dnscrypt) \
+ $(use_enable dnstap) \
+ $(use_with lmdb ) \
+ $(use_with regex re2) \
+ $(use_with snmp net-snmp) \
+ $(use ssl && { echo "--enable-dns-over-tls" && use_with gnutls && use_with !gnutls libssl;} || echo "--without-gnutls --without-libssl") \
+ $(use_enable systemd) \
+ $(use_enable test unit-tests)
+ sed 's/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl$libdir'\''/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl\/$libdir'\''/g' \
+ -i "${S}/configure"
+}
+
+src_install() {
+ default
+
+ insinto /etc/dnsdist
+ doins "${FILESDIR}"/dnsdist.conf.example
+
+ newconfd "${FILESDIR}"/dnsdist.confd ${PN}
+ newinitd "${FILESDIR}"/dnsdist.initd ${PN}
+}
+
+pkg_postinst() {
+ elog "dnsdist provides multiple instances support. You can create more instances"
+ elog "by symlinking the dnsdist init script to another name."
+ elog
+ elog "The name must be in the format dnsdist.<suffix> and dnsdist will use the"
+ elog "/etc/dnsdist/dnsdist-<suffix>.conf configuration file instead of the default."
+}