summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-02-18 07:06:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-02-18 14:43:13 +0100
commit9d47868b1143474e89658c3e3e1c9fae3b7b8ea1 (patch)
treec36766c86d90d0cfa22ae040baf2cbce93c6c954 /net-dns
parentdev-libs/zziplib: Remove myself as maintainer (diff)
downloadgentoo-9d47868b1143474e89658c3e3e1c9fae3b7b8ea1.tar.gz
gentoo-9d47868b1143474e89658c3e3e1c9fae3b7b8ea1.tar.bz2
gentoo-9d47868b1143474e89658c3e3e1c9fae3b7b8ea1.zip
net-dns/nsd: Bump to version 4.4.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.4.0.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 5cc63491117a..6ae76b067a12 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,2 +1,3 @@
DIST nsd-4.3.8.tar.gz 1225840 BLAKE2B 19d014f130844aab5b7c6224658c6e5a4a7d8d337ceb11e1641bceb367fe76b46be146c703296a12cec834020992eabec0e1ee8f3cb6211333ac8c4c7029fef5 SHA512 aec892f85a6757bfdf537c6f0b4bc3d60c564b3062b582af14df800b24261edc96bedcd0b6649444a46b198b9018397e356b919a871364032c8a2db6256b9268
DIST nsd-4.3.9.tar.gz 1222919 BLAKE2B 0b317c246f66476e95727d763bf7444cde14936c8a87036843458b89f8c79790130995db3f0f9ff33d8bfda756cf3ae4724b07f97ee2996f05a2dcd1c14bc0e5 SHA512 de170cbaf6e0be0a20941d9d6b2102a7dddb59a320c30566238447d5740e4497f751f54488f36c2b89f2c3cff6e3101df31a36d0d2d66db8d77cfb6e86124f32
+DIST nsd-4.4.0.tar.gz 1226433 BLAKE2B 8ead662c2ad87e9cfd9424898758cb7a7e6adc3c419583e0a4c3ced4d6bb8ae5005266af621ee4c138a06215652b60b65f075a875b6473dc92d1bef414901be1 SHA512 0fa32337246ccdaf9d6fe4257792cef8b6ce6de086fdee1024983da7b90a77b9039061cee87a2e0ad7eddf195411c57f4777469d973f2bdc10d3a51ee96d90bc
diff --git a/net-dns/nsd/nsd-4.4.0.ebuild b/net-dns/nsd/nsd-4.4.0.ebuild
new file mode 100644
index 000000000000..a41057e6300d
--- /dev/null
+++ b/net-dns/nsd/nsd-4.4.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+LICENSE="BSD"
+SLOT="0"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/NLnetLabs/nsd.git"
+else
+ # version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+ MY_PV="${PV/_beta/b}"
+ MY_PV="${MY_PV/_rc/rc}"
+ MY_P="${PN}-${MY_PV}"
+
+ [[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+IUSE="bind8-stats dnstap ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd"
+
+RDEPEND="
+ acct-group/nsd
+ acct-user/nsd
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ libevent? ( dev-libs/libevent )
+ munin? ( net-analyzer/munin )
+ ssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ systemd? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_prepare() {
+ default
+ # Required to get correct pkg-config macros with USE="systemd"
+ # see bugs #663618 and #758050
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --enable-tcp-fastopen
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable dnstap)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_enable systemd)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
+}