summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2021-02-09 01:54:03 +0100
committerSven Wegener <swegener@gentoo.org>2021-02-09 01:56:10 +0100
commitbbf5cc0a661cb80d47a7ef0a2854994674de0c26 (patch)
tree469f05dad6469224dbcb1321564ce217601dcbf1 /net-dns
parentmedia-video/pipewire: bump to v0.3.21 (diff)
downloadgentoo-bbf5cc0a661cb80d47a7ef0a2854994674de0c26.tar.gz
gentoo-bbf5cc0a661cb80d47a7ef0a2854994674de0c26.tar.bz2
gentoo-bbf5cc0a661cb80d47a7ef0a2854994674de0c26.zip
net-dns/pdns: Version bump to 4.4.1
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/Manifest1
-rw-r--r--net-dns/pdns/pdns-4.4.1.ebuild170
2 files changed, 171 insertions, 0 deletions
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index d41a44702d59..ec35608a43c4 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,2 +1,3 @@
DIST pdns-4.3.1.tar.bz2 1216876 BLAKE2B 0449835d104ec430329dc88087b489e29f1e1fa0c2a22af8715883a0a80d73f3a4848df207abbf986b946c640c4f1d35a1c8335f13f96a00915e4a40bcbecc9f SHA512 e61e23544f1e57c1ec3a85b4edbc3ff3e8e831410237afdc8896e9f34602774c1dc8bd02eb7440e765262fcc988f98e47b6f1b7945427b1f4a59dd6b84b9437e
DIST pdns-4.4.0.tar.bz2 1270854 BLAKE2B 2c855197d0b5f8fc141e4fa19268e68b9114353c7f89157023b9cd6b9559e788b55a9b0eeebea55d4ba0a206229d9c032f0c84c40ffd91c7277eb611a4bc966a SHA512 e7f35539915ee7945b537cfedae72e2b83c86b39c5e44a9268b8a086f44b30a33a64e0b65aad140ba02c349cedaa12820226578dea87c9b666dc75f8bd15c1f6
+DIST pdns-4.4.1.tar.bz2 1276990 BLAKE2B 9771cf3273ab7e8ab4607a91563bfe0dc3f4532b5420861d816eacd2798d66de3a1eb824c191264f9106ec47bd6003d99108b8df678190055948779b9b3b070f SHA512 a6f31972f77ded8ecfb523e8810dd90e5b7aa628746fee2a9a0daae2a7935800f111ce8617ffd71d5ce3881947d4ffc36c9cb37996a7bcc514536bb4abe1f79e
diff --git a/net-dns/pdns/pdns-4.4.1.ebuild b/net-dns/pdns/pdns-4.4.1.ebuild
new file mode 100644
index 000000000000..5e50badd2298
--- /dev/null
+++ b/net-dns/pdns/pdns-4.4.1.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# other possible flags:
+# db2: we lack the dep
+# oracle: dito (need Oracle Client Libraries)
+# xdb: (almost) dead, surely not supported
+
+IUSE="debug doc geoip ldap libressl lua-records mydns mysql postgres protobuf remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ mydns? ( mysql )"
+
+DEPEND="${LUA_DEPS}
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:=
+ lua-records? ( >=net-misc/curl-7.21.3 )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 app-crypt/mit-krb5 )
+ sqlite? ( dev-db/sqlite:3 )
+ geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
+ sodium? ( dev-libs/libsodium:= )
+ tinydns? ( >=dev-db/tinycdb-0.77 )
+ protobuf? ( dev-libs/protobuf )"
+RDEPEND="${DEPEND}
+ acct-user/pdns
+ acct-group/pdns"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}"/${P/_/-}
+
+src_configure() {
+ local dynmodules="pipe bind" # the default backends, always enabled
+
+ #use db2 && dynmodules+=" db2"
+ use ldap && dynmodules+=" ldap"
+ use mydns && dynmodules+=" mydns"
+ use mysql && dynmodules+=" gmysql"
+ #use oracle && dynmodules+=" goracle oracle"
+ use postgres && dynmodules+=" gpgsql"
+ use remote && dynmodules+=" remote"
+ use sqlite && dynmodules+=" gsqlite3"
+ use tinydns && dynmodules+=" tinydns"
+ use geoip && dynmodules+=" geoip"
+ #use xdb && dynmodules+=" xdb"
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-modules= \
+ --with-dynmodules="${dynmodules}" \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable lua-records) \
+ $(use_enable test unit-tests) \
+ $(use_enable tools) \
+ $(use_enable systemd) \
+ $(use_with sodium libsodium) \
+ $(use_with protobuf) \
+ ${myconf}
+}
+
+src_compile() {
+ default
+ use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ fperms 0700 /etc/powerdns
+ fperms 0600 /etc/powerdns/pdns.conf
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ newinitd "${FILESDIR}"/pdns-r1 pdns
+
+ keepdir /var/empty
+
+ if use doc; then
+ docinto html
+ dodoc -r codedocs/html/.
+ fi
+
+ # Install development headers
+ insinto /usr/include/pdns
+ doins pdns/*.hh
+ insinto /usr/include/pdns/backends/gsql
+ doins pdns/backends/gsql/*.hh
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/dnsdomain2.schema
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "PowerDNS provides multiple instances support. You can create more instances"
+ elog "by symlinking the pdns init script to another name."
+ elog
+ elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+ elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+ if use ldap ; then
+ echo
+ ewarn "The official LDAP backend module is only compile-tested by upstream."
+ ewarn "Try net-dns/pdns-ldap-backend if you have problems with it."
+ fi
+
+ local old
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 3.2 || continue
+
+ echo
+ ewarn "To fix a security bug (bug #458018) had the following"
+ ewarn "files/directories the world-readable bit removed (if set):"
+ ewarn " ${EPREFIX}/etc/powerdns"
+ ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
+ ewarn "Check if this is correct for your setup"
+ ewarn "This is a one-time change and will not happen on subsequent updates."
+ chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+ break
+ done
+
+ if use postgres; then
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.1.11-r1 || continue
+
+ echo
+ ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+ ewarn "This security fix needs to be applied manually to the database schema."
+ ewarn "Please refer to the official security advisory for more information:"
+ ewarn
+ ewarn " https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+ break
+ done
+ fi
+}