summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2022-10-20 22:02:36 +0200
committerSven Wegener <swegener@gentoo.org>2022-10-21 08:52:04 +0200
commitbd6dc210511bcbca796be2ed1c9cb7d1c450bec2 (patch)
treea53934adf38fb3e9ed314b62752ed9b8d1cbe38b /net-dns
parentsys-fs/cryptsetup: Stabilize 2.4.3-r2 sparc, #877775 (diff)
downloadgentoo-bd6dc210511bcbca796be2ed1c9cb7d1c450bec2.tar.gz
gentoo-bd6dc210511bcbca796be2ed1c9cb7d1c450bec2.tar.bz2
gentoo-bd6dc210511bcbca796be2ed1c9cb7d1c450bec2.zip
net-dns/pdns: Version bump to 4.7.0
Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/Manifest1
-rw-r--r--net-dns/pdns/pdns-4.7.0.ebuild170
2 files changed, 171 insertions, 0 deletions
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index f60ae1ab6846..2c6d3c171051 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1 +1,2 @@
DIST pdns-4.6.3.tar.bz2 1302651 BLAKE2B 58a66952293bd5caf7b03d114e11f4d6774f5f2aab969b33c1c510b745790f7276b9913cc03e3e4565e5b1de6f61decf338a3b6430d0429c2b87cc9690d9388d SHA512 ea44a0c929e36bf9002d8db7bf1e06ec372a08b31b60c74bbc3ea5600073fb745151f33798a0a4bd151ce17ad7efb07be30f7ddcf620d5bdaab6de4f37f4296f
+DIST pdns-4.7.0.tar.bz2 1361265 BLAKE2B 157e512da19c48c4a6aa32ef54525d4902b8aff8484c040ceca7ee15f4202acb3f7ed93152a625f858b475193b9c295fe3fc264caabbcf456fc92224786050a6 SHA512 d4ed9acb98b8195f6f8821d4934472f214bbb4cbef67d084c0b9836e61c9cf156eb193b6e4769ae088aaf92f1ca65dc3ab35fdfcacc42eeb9804d80ab92b25e2
diff --git a/net-dns/pdns/pdns-4.7.0.ebuild b/net-dns/pdns/pdns-4.7.0.ebuild
new file mode 100644
index 000000000000..4f2153110553
--- /dev/null
+++ b/net-dns/pdns/pdns-4.7.0.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# other possible flags:
+# db2: we lack the dep
+# oracle: dito (need Oracle Client Libraries)
+# xdb: (almost) dead, surely not supported
+
+IUSE="debug doc geoip ldap lmdb lua-records mydns mysql postgres remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ mydns? ( mysql )"
+
+DEPEND="${LUA_DEPS}
+ dev-libs/openssl:=
+ dev-libs/boost:=
+ lmdb? ( >=dev-db/lmdb-0.9.29 )
+ lua-records? ( >=net-misc/curl-7.21.3 )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( >=net-nds/openldap-2.0.27-r4:= app-crypt/mit-krb5 )
+ sqlite? ( dev-db/sqlite:3 )
+ geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
+ sodium? ( dev-libs/libsodium:= )
+ tinydns? ( >=dev-db/tinycdb-0.77 )
+ elibc_glibc? ( x86? ( >=sys-libs/glibc-2.34 ) )"
+RDEPEND="${DEPEND}
+ acct-user/pdns
+ acct-group/pdns"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ local cnf_dynmodules="pipe bind" # the default backends, always enabled
+
+ #use db2 && cnf_dynmodules+=" db2"
+ use ldap && cnf_dynmodules+=" ldap"
+ use lmdb && cnf_dynmodules+=" lmdb"
+ use mydns && cnf_dynmodules+=" mydns"
+ use mysql && cnf_dynmodules+=" gmysql"
+ #use oracle && cnf_dynmodules+=" goracle oracle"
+ use postgres && cnf_dynmodules+=" gpgsql"
+ use remote && cnf_dynmodules+=" remote"
+ use sqlite && cnf_dynmodules+=" gsqlite3"
+ use tinydns && cnf_dynmodules+=" tinydns"
+ use geoip && cnf_dynmodules+=" geoip"
+ #use xdb && cnf_dynmodules+=" xdb"
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-modules= \
+ --with-dynmodules="${cnf_dynmodules}" \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable lua-records) \
+ $(use_enable test unit-tests) \
+ $(use_enable tools) \
+ $(use_enable systemd) \
+ $(use_with sodium libsodium) \
+ ${myconf}
+}
+
+src_compile() {
+ default
+ use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ fperms 0700 /etc/powerdns
+ fperms 0600 /etc/powerdns/pdns.conf
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ newinitd "${FILESDIR}"/pdns-r1 pdns
+
+ keepdir /var/empty
+
+ if use doc; then
+ docinto html
+ dodoc -r codedocs/html/.
+ fi
+
+ # Install development headers
+ insinto /usr/include/pdns
+ doins pdns/*.hh
+ insinto /usr/include/pdns/backends/gsql
+ doins pdns/backends/gsql/*.hh
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/dnsdomain2.schema
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "PowerDNS provides multiple instances support. You can create more instances"
+ elog "by symlinking the pdns init script to another name."
+ elog
+ elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+ elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+ local old
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 3.2 || continue
+
+ echo
+ ewarn "To fix a security bug (bug #458018) had the following"
+ ewarn "files/directories the world-readable bit removed (if set):"
+ ewarn " ${EPREFIX}/etc/powerdns"
+ ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
+ ewarn "Check if this is correct for your setup"
+ ewarn "This is a one-time change and will not happen on subsequent updates."
+ chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+ break
+ done
+
+ if use postgres; then
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.1.11-r1 || continue
+
+ echo
+ ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+ ewarn "This security fix needs to be applied manually to the database schema."
+ ewarn "Please refer to the official security advisory for more information:"
+ ewarn
+ ewarn " https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+ break
+ done
+ fi
+}